Minimum Inversion Number (单点更新 线段树 )

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19112    Accepted Submission(s): 11525


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author

    总共有N个数,如何判断第i+1个数到最后一个数之间有多少个数小于第i个数呢?不妨假设有一个区间 [1,N],只需要判断区间[i+1,N]之间有多少个数小于第i个数。如果我们把总区间初始化为0,然后把第i个数之前出现过的数都在相应的区间把它的值定为1,那么问题就转换成了[i+1,N]值的总和。再仔细想一下,区间[1,i]的值+区间[i+1,N]的值=区间[1,N]的值(i已经标记为1),所以区间[i+1,N]值的总和等于N-[1,i]的值!因为总共有N个数,不是比它小就是比它(大或等于)。

        现在问题已经转化成了区间问题,枚举每个数,然后查询这个数前面的区间值的总和,i-[1,i]既为逆序数。

        线段树预处理时间复杂度O(NlogN),N次查询和N次插入的时间复杂度都为O(NlogN),总的时间复杂度O(3*NlogN)

/*num数组 是把记录 数是否存在 存在即为1。
总共有N个数,如何判断第i+1个数到最后一个
数之间有多少个数小于第i个数呢?不妨假设
有一个区间 [1,N],只需要判断区间[i+1,N]之
间有多少个数小于第i个数。如果我们把总区间初
始化为0,然后把第i个数之前出现过的数都在相应
的区间把它的值定为1,那么问题就转换成了[i+1,N]
值的总和
*/
#include <stdio.h>
#define lson l, m, rt<<1
#define rson m+1, r, rt<<1|1
#define size 5005
#define min(a, b) a > b ? b : a
int num[size << 2], x[size];
void pushup(int rt)
{
    num[rt] = num[rt << 1] + num[rt << 1 | 1];
}
void build( int l, int r, int rt)
{
    num[rt] = 0;
    if( l == r) return;
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
}

int qurey( int L, int R, int l, int r, int rt)
{
    if( L <= l && r <= R)
        return num[rt];
    int m = (l + r) >> 1;
    int ans = 0;
    if(L <= m) ans+=qurey(L, R, lson);
    if(R > m) ans+=qurey(L, R, rson);
    return ans;
}
void updata( int p, int l, int r, int rt)
{
    if( l == r)
    {
        num[rt]++;return;
    }
    int m = ( l + r) >> 1;
    if( p <= m) updata(p, lson);
    else updata(p, rson);
    pushup(rt);
}
int main()
{
    int n;
    while(~scanf("%d", &n))
    {
        int sum = 0;
        build(0, n - 1, 1);
        for( int i= 1; i <= n; i++)
        {
            scanf("%d", &x[i]);
            sum += qurey(x[i], n - 1, 0, n - 1, 1);
            updata(x[i], 0, n - 1, 1);

        }
        int tmp = sum;
        for( int i = 1; i <= n; i++)
        {
            sum += n - x[i] - x[i] - 1;
            tmp = min(tmp, sum);
        }
         printf("%d\n",tmp);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值