Problem B: B--Faultfinding ytu师创杯

Problem B: B--Faultfinding

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 60   Solved: 29
[ Submit][ Status][ Web Board]

Description

Do you remember the game in which we find difference among several similar pictures? Now we change it into digital version. There are N digits, same or different. Please find how many different digits there are among them and output the number.

Input

Each group of the first line is N (1<=N<=10000). The second line consists N integers.

Output

The number of different digits.

Sample Input

2
1 1
3 
1 2 3

Sample Output

1
3
ACcode:
#include <iostream>

using namespace std;
int a[10001];
int main()
{
    int n,ant;
    while(cin>>n)
    {
        ant=1;
        for(int i=0; i<n; i++)
            cin>>a[i];
        for(int i=1; i<n; i++)
            for(int j=i-1; j>=0; j--)
            {
                if(a[i]==a[j])
                    break;
                if(j==0)
                    ant++;
            }
        cout<<ant<<endl;
    }
    return 0;
}
学习总结:
又学会了一种找一组数中不同数字的方法
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值