Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33039 Accepted Submission(s): 14624
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33039 Accepted Submission(s): 14624
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
//这题的主要思路:直接利用dfs搜索满足头为1 两点之间的和为素数
#include <stdio.h>
int a[21],n,cnt;
int vis[21];
int cnt1=0;
int k[21];
int prime(int n) //判断素数
{
if(n==1) return 0;
for(int i=2;i*i<=n;i++)
{
if(n%i==0)
return 0;
}
return 1;
}
void dfs(int ini)
{
if(cnt1==n&&prime(k[n-1]+1)&&k[0]==1) //头为1 头尾相加为素数 长度为n
{
printf("%d",k[0]);
for(int i=1;i<n;i++)
printf(" %d",k[i]);
printf("\n");
}
else
{
for(int i=0;i<n;i++)
{
if(!vis[i]&&prime(a[i]+a[ini]))
{
vis[i]=1;
k[cnt1++]=a[i];
dfs(i);
cnt1--; //回溯
vis[i]=0;
}
}
}
}
int main()
{
cnt=1;
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++)
{
a[i]=i+1;
vis[i]=0;
}
printf("Case %d:\n",cnt++);
dfs(0);
printf("\n");
}
return 0;
}