HDU 5339

Untitled

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 828    Accepted Submission(s): 460

Problem Description
There is an integer a and n integers b1,…,bn. After selecting some numbers from b1,…,bn in any order, say c1,…,cr, we want to make sure that a mod c1 mod c2 mod… mod cr=0 (i.e., a will become the remainder divided by ci each time, and at the end, we want a to become 0). Please determine the minimum value of r. If the goal cannot be achieved, print −1 instead.
 
Input
The first line contains one integer T≤5, which represents the number of testcases. 
For each testcase, there are two lines:
1. The first line contains two integers n and a (1≤n≤20,1≤a≤106).
2. The second line contains n integers b1,…,bn (∀1≤i≤n,1≤bi≤106).
 
Output
Print T answers in T lines.
 
Sample Input
2
2 9
2 7
2 9
6 7
 
Sample Output
2

-1

//题意:给你n个数 在n个数中调出最少的元素使得 m%a1%a2%a3=0不存在就输出-1

//搜索

#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
using namespace std;
int m,n;
int d[1000010];
bool vis[1000010];

struct Node
{
    int x,step;
};

int bfs(int x)
{
    queue<Node>q;
    Node a;
    a.x=x,a.step=0;
    q.push(a);
    while(!q.empty())
    {
        Node b=q.front();
        q.pop();
        vis[b.x]=1;
        if(b.x==0)return b.step;
        for(int i=n-1;i>=0;i--)
        {
            Node c=b;
            c.x=c.x%d[i];
            c.step++;
            if(!vis[c.x])
            {
                vis[c.x]=1;
                q.push(c);
            }
        }
    }
    return 0;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(d,0,sizeof(d));
        memset(vis,0,sizeof(vis));
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&d[i]);
        }
            int cnt=bfs(m);
            if(cnt==0)
                printf("-1\n");
            else
                printf("%d\n",cnt);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值