The shortest problem
(Java/Others)
Total Submission(s): 1484 Accepted Submission(s): 686
Problem Description
In this problem, we should solve an interesting game. At first, we
have an integer n, then we begin to make some funny change. We sum up
every digit of the n, then insert it to the tail of the number n, then
let the new number be the interesting number n. repeat it for t times.
When n=123 and t=3 then we can get 123->1236->123612->12361215.
Input
Multiple input.
We have two integer n (0<=n<=104 ) , t(0<=t<=105) in each row.
When n==-1 and t==-1 mean the end of input.
Output
For each input , if the final number are divisible by 11, output “Yes
”, else output ”No”. without quote.
Sample Input
35 2
35 1
-1 -1
Sample Output
Case #1: Yes
Case #2: No
//不要用sprintf 功能太多时间复杂度太大
#include <stdio.h>
#include <cmath>
using namespace std;
char s[1000011];
int k,an=0;
int sprint(char s[],int n)
{
char ss[10000];
int cnt=0;
int t=0;
while(n)
{
ss[cnt++]=n%10+'0';
t+=n%10;
n/=10;
}
for(int i=cnt-1;i>=0;i--)
s[k++]=ss[i];
s[k]='\0';
return t;
}
int main()
{
int n,m,cas=1;
while(~scanf("%d%d",&n,&m))
{
if(n==-1&&m==-1)
break;
k=0;
int val=sprint(s,n);
while(m--)
{
val+=sprint(s,val);
//puts(s);
}
int sum1,sum2;
sum1=sum2=0;
for(int i=0;s[i]!='\0';i++)
{
if(i%2==1)
sum1+=s[i]-'0';
else
sum2+=s[i]-'0';
}
if(int(abs(sum1-sum2))%11==0)
printf("Case #%d: Yes\n",cas++);
else
printf("Case #%d: No\n",cas++);
}
return 0;
}