HDU 5479(栈的应用)

18 篇文章 0 订阅

Scaena Felix

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 426    Accepted Submission(s): 186


Problem Description
Given a parentheses sequence consist of '(' and ')', a modify can filp a parentheses, changing '(' to ')' or ')' to '('.

If we want every not empty <b>substring</b> of this parentheses sequence not to be "paren-matching", how many times at least to modify this parentheses sequence?

For example, "()","(())","()()" are "paren-matching" strings, but "((", ")(", "((()" are not.
 

Input
The first line of the input is a integer  T , meaning that there are  T  test cases.

Every test cases contains a parentheses sequence  S  only consists of '(' and ')'.

1|S|1,000 .
 

Output
For every test case output the least number of modification.
 

Sample Input
  
  
3 () (((( (())
 

Sample Output
  
  
1 0 2
 
//判断()的个数行
// 利用栈的先进后出的特点模拟
#include <stdio.h>
#include <string.h>
#include <stack>
using namespace std;
char str[1000+10];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        getchar();
        scanf("%s",str);
        stack <char> s;
        int len=strlen(str);
        int cnt=0;
        for(int i=0;i<len;i++)
        {
            if(str[i]=='(')
                s.push(str[i]);
            else if(str[i]==')')
            {
                if(!s.empty())  //判断是否为空
                {
                    s.pop();
                    cnt++;
                }
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值