HDU 5317(打表)

RGCDQ

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2261    Accepted Submission(s): 923


Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know  maxGCD(F(i),F(j))   (Li<jR)
 

Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
 

Output
For each query,output the answer in a single line. 
See the sample for more details.
 

Sample Input
  
  
2 2 3 3 5
 

Sample Output
  
  
1 1
 

//当时多校没做出来。。今天回过头来想想其实并不是很难
//题意:定义一个函数f(x)=x的素数因子的个数  给你L R 求 res=maxGCD(f(i),f(j)) L<=i<j<=R
//数据量大 只能打表
//首先一个素数表是肯定的  接着要求素数因子的个数 我们可以在打表的过程中遇到是素数 他的倍数都加1
//求GCD的时候我们自己算下或者测下数据可以发现最大的素数因子个数是7 可以开一个数组记录前缀和 接着特判下
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int vis[1000010];
int prime[1000010];
int res[1000010];
int ans[1000010][9];
void Prime()
{
    memset(vis,0,sizeof(vis));
    memset(res,0,sizeof(res));
    memset(prime,0,sizeof(prime));
    for(int i=2;i<=1000000;i++)  //素数打表
    {
        if(!vis[i])
        {
            prime[i]=1;
            for(int k=i;k<=1000000;k+=i)
            {
                vis[k]=1;
                if(prime[i])  当i是素数时他的倍数都有一个素数的因子
                    res[k]++;
            }
        }
    }
}
void function()
{
    memset(ans,0,sizeof(ans));  
    for(int i=2;i<=1000000;i++) //求前缀和
    {
        for(int k=1;k<8;k++)
            ans[i][k]=ans[i-1][k];
        ans[i][res[i]]++;
    }
}
int main()
{
    Prime();
    function();
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        int flag=0;
        for(int i=7;i>=1;i--) //特判  7 7  6 6  5 5  4 4  3 3  6 3  6 4  6 2  4 2  2 2  1
        {
            if(i>=3)
            {               
                if(ans[m][i]-ans[n-1][i]>=2)  
                {
                    flag=1;
                    printf("%d\n",i);
                    break;
                }
            }
            else
            {
                if(ans[m][6]-ans[n-1][6]==1&&ans[m][3]-ans[n-1][3]==1)
                {
                    flag=1;
                    printf("3\n");
                    break;
                }
                if((ans[m][6]-ans[n-1][6]==1&&ans[m][4]-ans[n-1][4]==1)||(ans[m][2]-ans[n-1][2]>=2)||(ans[m][4]-ans[n-1][4]==1&&ans[m][2]-ans[n-1][2]==1)||(ans[m][6]-ans[n-1][6]==1&&ans[m][2]-ans[n-1][2]==1))  //刚刚才发现我AC的代码少了个6 2   hdu 数据有点水啊
                {
                    flag=1;
                    printf("2\n");
                    break;
                }
            }
        }
        if(!flag)
            printf("1\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值