POJ 3468(区间更新)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 81386 Accepted: 25137
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

//简单的区间更新 注意int太小 会越界

#include <stdio.h>
using namespace std;
const int maxn=100000+10;
__int64 ans;
__int64 arr[maxn];
struct Node
{
    __int64 l,r;
    __int64 val,flag;
    int mid()
    {
        return (l+r)/2;
    }
}tree[maxn*4];
void Buildtree(__int64 rt,__int64 l,__int64 r)
{
    tree[rt].l=l;
    tree[rt].r=r;
    tree[rt].val=tree[rt].flag=0;
    if(l!=r)
    {
        Buildtree(2*rt,l,(l+r)/2);
        Buildtree(2*rt+1,(l+r)/2+1,r);
        tree[rt].val=tree[2*rt].val+tree[2*rt+1].val;
    }
    else
        tree[rt].val=arr[tree[rt].l-1];
}
void Pushdown(__int64 rt)
{
    tree[2*rt].flag+=tree[rt].flag;
    tree[2*rt+1].flag+=tree[rt].flag;
    tree[2*rt].val+=(tree[2*rt].r-tree[2*rt].l+1)*tree[rt].flag;
    tree[2*rt+1].val+=(tree[1+2*rt].r-tree[1+2*rt].l+1)*tree[rt].flag;
    tree[rt].flag=0;
}

void Pushup(__int64 rt)
{
    tree[rt].val=tree[2*rt].val+tree[2*rt+1].val;
}

void Update(__int64 rt,__int64 l,__int64 r,__int64 val)
{
    if(tree[rt].l==l&&tree[rt].r==r)
    {
        tree[rt].val+=(r-l+1)*val;
        tree[rt].flag+=val;
        return;
    }
    if(tree[rt].flag)
        Pushdown(rt);
    if(r<=tree[rt].mid())
        Update(2*rt,l,r,val);
    else if(l>tree[rt].mid())
        Update(2*rt+1,l,r,val);
    else
    {
        Update(2*rt,l,tree[rt].mid(),val);
        Update(2*rt+1,tree[rt].mid()+1,r,val);
    }
    Pushup(rt);
}
void Query(__int64 rt,__int64 l,__int64 r)
{
    if(tree[rt].l==l&&tree[rt].r==r)
    {
        ans+=tree[rt].val;
        return;
    }
    if(tree[rt].flag)
        Pushdown(rt);
    if(r<=tree[rt].mid())
        Query(2*rt,l,r);
    else if(l>tree[rt].mid())
        Query(2*rt+1,l,r);
    else
    {
        Query(2*rt,l,tree[rt].mid());
        Query(2*rt+1,tree[rt].mid()+1,r);
    }
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        char s[2];
        for(int i=0;i<n;i++)
            scanf("%I64d",arr+i);
        Buildtree(1,1,n);
        while(m--)
        {
            scanf("%s",s);
            if(s[0]=='C')
            {
                __int64 l,r,val;
                scanf("%I64d%I64d%I64d",&l,&r,&val);
                Update(1,l,r,val);
            }
            else if(s[0]=='Q')
            {
                __int64 l,r;
                scanf("%I64d%I64d",&l,&r);
                ans=0;
                Query(1,l,r);
                printf("%I64d\n",ans);
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值