HDU 5480(前缀和||树状数组)

Conturbatio

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 457    Accepted Submission(s): 208


Problem Description
There are many rook on a chessboard, a rook can attack the row and column it belongs, including its own place.

There are also many queries, each query gives a rectangle on the chess board, and asks whether every grid in the rectangle will be attacked by any rook?
 

Input
The first line of the input is a integer  T , meaning that there are  T  test cases.

Every test cases begin with four integers  n,m,K,Q .
K  is the number of Rook,  Q  is the number of queries.

Then  K  lines follow, each contain two integers  x,y  describing the coordinate of Rook.

Then  Q  lines follow, each contain four integers  x1,y1,x2,y2  describing the left-down and right-up coordinates of query.

1n,m,K,Q100,000 .

1xn,1ym .

1x1x2n,1y1y2m .
 

Output
For every query output "Yes" or "No" as mentioned above.
 

Sample Input
  
  
2 2 2 1 2 1 1 1 1 1 2 2 1 2 2 2 2 2 1 1 1 1 2 2 1 2 2
 

Sample Output
  
  
Yes No Yes
Hint
Huge input, scanf recommended.
 
//开两个数组将行和列  出现的个数累加  询问时只要行或者列个数之和等于x2-x1+1||y2-y1+1
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <algorithm>
#include <map>
#include <queue>
using namespace std;
const int maxn=100000+10;
const int inf=(1<<30);
int row[maxn],col[maxn];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m,k,q;
        memset(row,0,sizeof(row));
        memset(col,0,sizeof(col));
        scanf("%d%d%d%d",&n,&m,&k,&q);
        while(k--)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            row[a]=1,col[b]=1;  //赋值为1  有可能出现相同的不能累加
        }
        for(int i=1;i<=n;i++)
        {
            row[i]+=row[i-1];
        }
        for(int i=1;i<=m;i++)
        {
            col[i]+=col[i-1];
        }
        while(q--)
        {
            int x1,y1,x2,y2,res1,res2;
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            res1=row[x2]-row[x1-1];
            res2=col[y2]-col[y1-1];
            if(res1==(x2-x1+1)||res2==(y2-y1+1))
                printf("Yes\n");
            else
                printf("No\n");
        }
    }
    return 0;
}

树状数组 -- 思路一样
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <algorithm>
#include <map>
#include <queue>
using namespace std;
const int maxn=100000+10;
const int inf=(1<<30);
int row[maxn],col[maxn];
bool vis[maxn],vis1[maxn];
int lowbit(int x)
{
    return x&(-x);
}
void add(int i,int val,int c[],int k)
{
    while(i<=k)
    {
        c[i]+=val;
        i+=lowbit(i);
    }
}

int sum(int i,int c[])
{
    int sum=0;
    while(i)
    {
        sum+=c[i];
        i-=lowbit(i);
    }
    return sum;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m,k,q;
        memset(row,0,sizeof(row));
        memset(col,0,sizeof(col));
        memset(vis,0,sizeof(vis));
        memset(vis1,0,sizeof(vis1));
        scanf("%d%d%d%d",&n,&m,&k,&q);
        while(k--)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            if(!vis[a])   //判断是否出现过
                add(a,1,row,n);
            if(!vis1[b])
                add(b,1,col,m);
            vis[a]=vis1[b]=1;
        }
        while(q--)
        {
            int x1,y1,x2,y2,res1,res2;
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            res1=sum(x2,row)-sum(x1-1,row);
            res2=sum(y2,col)-sum(y1-1,col);
            if(res1==(x2-x1+1)||res2==(y2-y1+1))
                printf("Yes\n");
            else
                printf("No\n");
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值