hdu 5616(dp)

27 篇文章 0 订阅

Jam's balance

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 733    Accepted Submission(s): 351


Problem Description
Jim has a balance and N weights.  (1N20)
The balance can only tell whether things on different side are the same weight.
Weights can be put on left side or right side arbitrarily.
Please tell whether the balance can measure an object of weight M.
 

Input
The first line is a integer  T(1T5) , means T test cases.
For each test case :
The first line is  N , means the number of weights.
The second line are  N  number, i'th number  wi(1wi100)  means the i'th weight's weight is  wi .
The third line is a number  M M  is the weight of the object being measured.
 

Output
You should output the "YES"or"NO".
 

Sample Input
  
  
1 2 1 4 3 2 4 5
 

Sample Output
  
  
NO YES YES
Hint
For the Case 1:Put the 4 weight alone For the Case 2:Put the 4 weight and 1 weight on both side
 

Source

BestCoder Round #70


//好久没刷题了。。这题求的是给你N个数是否可以通过加减运算得到另外一个数

//主要利用类01背包的思想 dp[i][k] 为前i个数是否可以得到k 可以得到为1不能得到为0

//dp[i][k] = max(dp[i-1][k],dp[i-1][abs(k-a[i])]); dp[i][k] =max(dp[i][k],dp[i-1][k+a[i]]) 

#include <bits/stdc++.h>
using namespace std;
const int N=25;
int arr[N];
int dp[N][N*100];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0;i<=n;i++)
            for(int k=0;k<N*100;k++)
                dp[i][k]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",arr+i);
            dp[i][0]=1;
        }
        dp[0][0]=1;
        for(int i=1;i<=n;i++)
        {
            for(int k=1;k<n*100;k++)
            {
                dp[i][k]=max(dp[i-1][k],dp[i-1][abs(k-arr[i])]);
                dp[i][k]=max(dp[i][k],dp[i-1][k+arr[i]]);
            }
        }
        int m;
        scanf("%d",&m);
        while(m--)
        {
            int val;
            scanf("%d",&val);
            if(dp[n][val])
                puts("YES");
            else
                puts("NO");
        }
    }

    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值