HDU5616 Jam's balance 动态规划

Jam's balance

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 774    Accepted Submission(s): 374


Problem Description
Jim has a balance and N weights.  (1N20)
The balance can only tell whether things on different side are the same weight.
Weights can be put on left side or right side arbitrarily.
Please tell whether the balance can measure an object of weight M.
 

Input
The first line is a integer  T(1T5) , means T test cases.
For each test case :
The first line is  N , means the number of weights.
The second line are  N  number, i'th number  wi(1wi100)  means the i'th weight's weight is  wi .
The third line is a number  M M  is the weight of the object being measured.
 

Output
You should output the "YES"or"NO".
 

Sample Input
  
  
1 2 1 4 3 2 4 5
 

Sample Output
  
  
NO YES YES
Hint
For the Case 1:Put the 4 weight alone For the Case 2:Put the 4 weight and 1 weight on both side
 

题目大意:告诉你N个砝码,问能否测量出质量为M的物品。

分析:动态规划,对于前X个砝码,若能组合出质量为K的物品,则需要前X-1个砝码能组合出K-W[X]或K+W[X]或K的重量。

最后直接访问DP数组即可。

CODE:

//************************************************************************//
//*Author : Handsome How                                                 *//
//************************************************************************//
//#pragma comment(linker, "/STA    CK:1024000000,1024000000")
#pragma warning(disable:4996) 
#include <vector>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <algorithm>
#include <sstream>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <ctime>                                                
#include <cassert>
#if defined(_MSC_VER) || __cplusplus > 199711L
#define aut(r,v) auto r = (v)
#else
#define aut(r,v) __typeof(v) r = (v)
#endif
#define each(it,o) for(aut(it, (o).begin()); it != (o).end(); ++ it)
#define fur(i,a,b) for(int i=(a);i<=(b);i++)
#define furr(i,a,b) for(int i=(a);i>=(b);i--)
#define cl(a) memset((a),0,sizeof(a))
using namespace std;
typedef long long LL;
//----------------------------------------------------
bool dp[25][2500];
int    a[30];
int main()
{
    //freopen("E:\\data.in", "r", stdin);
    ios :: sync_with_stdio(false);
    int T;
    scanf("%d", &T);
    while (T--)
    {
        int n;
        scanf("%d", &n);
        fur(i, 1, n)scanf("%d", &a[i]);
        cl(dp);
        dp[0][0] = true;
        fur(i, 1, n)fur(j, 0, 2000) {
            if (j >= a[i])
                if (dp[i - 1][j - a[i]])
                    dp[i][j] = 1;
            if (j + a[i] <= 2000)
                if (dp[i - 1][j + a[i]])
                    dp[i][j] = 1;
            if (dp[i - 1][j])
                dp[i][j] = 1;
        }
        int q;
        scanf("%d", &q);
        while (q--)
        {
            int t;
            scanf("%d", &t);
            if (t > 2000) {
                printf("NO\n");
                continue;
            }
            if (dp[n][t]) {
                printf("YES\n");
                continue;
            }
            printf("NO\n");
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值