hdu 5656 dp

27 篇文章 0 订阅

CA Loves GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1212    Accepted Submission(s): 397


Problem Description
CA is a fine comrade who loves the party and people; inevitably she loves GCD (greatest common divisor) too. 
Now, there are  N  different numbers. Each time, CA will select several numbers (at least one), and find the GCD of these numbers. In order to have fun, CA will try every selection. After that, she wants to know the sum of all GCDs. 
If and only if there is a number exists in a selection, but does not exist in another one, we think these two selections are different from each other.
 

Input
First line contains  T  denoting the number of testcases.
T  testcases follow. Each testcase contains a integer in the first time, denoting  N , the number of the numbers CA have. The second line is  N  numbers. 
We guarantee that all numbers in the test are in the range [1,1000].
1T50
 

Output
T  lines, each line prints the sum of GCDs mod  100000007 .
 

Sample Input
  
  
2 2 2 4 3 1 2 3
 

Sample Output
  
  
8 10
 

Source

看了题解才知道是个dp 比赛中一直以为是数论题。。。(不过有大神用了容斥做的)
题目要求给你n个数问所有组合的最大公约数求和%10e8+7
令dp[i][j] 为前i个数取若干个数的gcd为j的方法数
dp[i][j]+=dp[i-1][j]  前i个数肯定包含前i-1个数的方法
当我们加入第i个数a[i] 会对原先的状态产生什么影响呢?
dp[i][gcd(a[i],j)]+=dp[i-1][j]  前i-1个数gcd为j的方法数有dp[i-1][j]个 a[i]与j 产生的gcd的方法数可以再加上dp[i-1][j] 个

#include <bits/stdc++.h>
using namespace std;
#define ll long long
const int Mod=100000007;
int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}
int a[1005];
int GCD[1005][1005];
__int64 dp[1005][1005];
void gg()
{
    memset(GCD,0,sizeof(GCD));
    for(int i=1;i<1005;i++)
        for(int k=1;k<1005;k++)
            GCD[i][k]=GCD[k][i]?GCD[k][i]:gcd(k,i);
}

int main()
{
    int t;
    gg();
    scanf("%d",&t);
    while(t--)
    {
        int n;
        int tem=0;
        scanf("%d",&n);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",a+i);
            tem=max(tem,a[i]);
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=tem;j++)
            {
                dp[i][j]=(dp[i][j]+dp[i-1][j]+(a[i]==j))%Mod; //当a[i] == j 时个数加1 记得取模
                dp[i][GCD[a[i]][j]]=(dp[i][GCD[a[i]][j]]+dp[i-1][j])%Mod;
            }
        }
        ll res=0;
        for(ll j=1;j<=tem;j++)
        {
            res=(res+dp[n][j]*j)%Mod;
        }
        printf("%lld\n",res);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值