hdu 2256(矩阵快速幂)

Problem of Precision

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1226    Accepted Submission(s): 731


Problem Description

 

Input
The first line of input gives the number of cases, T. T test cases follow, each on a separate line. Each test case contains one positive integer n. (1 <= n <= 10^9)
 

Output
For each input case, you should output the answer in one line.
 

Sample Input
  
  
3 1 2 5
 

Sample Output
  
  
9 97 841
 

Source

#include <bits/stdc++.h>
using namespace std;

int Mod=1024;
struct Matrix
{
    int ma[2][2];
    Matrix(){
        memset(ma,0,sizeof(ma));
    }
    void init(int a,int b,int c,int d){
        ma[0][0]=a;ma[0][1]=b;
        ma[1][0]=c;ma[1][1]=d;
    }
    Matrix operator * (const Matrix &m)
    {
        Matrix res;
        for(int i=0;i<2;i++)
            for(int j=0;j<2;j++)
                for(int k=0;k<2;k++)
                    res.ma[i][j]=(res.ma[i][j]+ma[i][k]*m.ma[k][j])%Mod;
        return res;
    }
};
Matrix quick_pow(Matrix m,int n)
{
    if(n==1)return m;
    Matrix res=quick_pow(m,n/2);
    Matrix ans=res*res;
    if(n%2==1)
        ans=ans*m;
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        Matrix m,res;
        m.init(5,2,12,5);
        res=quick_pow(m,n);
        printf("%d\n",(2*res.ma[0][0]-1)%Mod);
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值