贪心-F FatMouse's Trade

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

题的意思是,用猫粮去每个房间交换豆豆,求最多能换取多少豆豆。先输入两个整数m,n。m表示现在有多少猫粮,n表示有n个房间。在下面输入n个房间的两个数据J[i]和F[i],表示需要用F[i]猫粮交换J[i]豆豆,如果猫粮不够时,也可以用F[i]*a%猫粮交换J[i]*a%豆豆。
用贪心做这个题,首先求出每个房间的性价比,当猫粮足够多时,按房间的性价比由高到低换取;当猫粮的量不足以换取整个房间的豆豆时,则按比例换取。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node//定义一个结构体包括豆豆,猫粮,性价比
{
    int beans;
    int food;
    double ratio;
}a[1000];
bool cmp(node a,node b)//排序函数
{
    return a.ratio>b.ratio;
}
int main()
{
    int m,n;
    while(cin>>m>>n&&m!=-1)
    {
        double sum=0;
        for(int i=0;i<n;i++)
        {
           cin>>a[i].beans>>a[i].food;
           a[i].ratio=a[i].beans*1.0/a[i].food;//计算性价比
        }
        sort(a,a+n,cmp);//按性价比将结构体从大到小排序
        for(int i=0;i<n&&m>0;i++)
        {
            if(m>a[i].food)//能全部换取的话
            {
                sum+=a[i].beans;
                m-=a[i].food;
            }
            else//不能全部换取的话
            {
                sum+=1.0*m/a[i].food*a[i].beans;
                m=0;
            }
        }
         printf("%.3lf\n",sum);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值