Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4
Case 2: 7 1 6
最大子段和问题,不同的是要输出开始和结束的位置。注意每种情况中间隔了一行(因为这个WA了好几遍)。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[100010];
int a[100010];
int main()
{
int t;
scanf("%d",&t);
int b=0;
while(t--)
{
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
dp[1]=a[1];
for(int i=2;i<=n;i++)
{
if(dp[i-1]<0)
dp[i]=a[i];
else
dp[i]=dp[i-1]+a[i];
}
int max=dp[1];
int end=1;
for(int i=2;i<=n;i++)
{
if(max<dp[i])
{
max=dp[i];
end=i;
}
}
int start=end;
int sum=0;
for(int i=end;i>=1;i--)
{
sum+=a[i];
if(sum==max)
{
start=i;
}
}
printf("Case %d:\n",++b);
printf("%d %d %d\n",max,start,end);
if(t)
printf("\n");
}
return 0;
}