PAT_ A1055 The World's Richest——排序

 

简单题,题目意思是给一堆人的信息,让你找出符合某个年龄段的排序结果。

虽然这道题简单,但架不住我脑残,废了九牛二虎写了一堆佶屈聱牙的代码,只为了实现一个小小的功能。为了把我的脑残经历记录下来,决定开始写这个博客,路过的大神请轻拍!满分代码我也有摘录,在我代码的下面。

 

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification: 

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10​5​​) - the total number of people, and K (≤10​3​​) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10​6​​,10​6​​]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [AminAmax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the Mrichest people with their ages in the range [AminAmax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

我的代码思想:

既然是考察有条件的排序,那就可以设置两个结构体,并进行两次排序。

第一次排序是全体记录按照 age 排序,第二次是在前面排序的基础上根据每次的 [min_age , max_age]进行二次排序,并把排序结果存储到临时结构体中。

该思想弊端:麻烦&易错。完全可以直接按照worth排序,然后把满足条件的记录挑出来。

满分代码在我的代码下面,可以比对一下。

还有一点需要注意:我的代码第二个测试点超时了。解决办法是把每个年龄的前100名挑出来,新建数组存放。

下面是我的代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 100010;
struct Record{
	char name[10];
	int age;
	int worth;
}rec[maxn],temp[maxn];

bool cmp1(Record a,Record b)
{
	return a.age<b.age;
}

bool cmp2(Record a,Record b)
{
	if(a.worth!=b.worth)
		return a.worth>b.worth;
	else if(a.age!=b.age)
		return a.age<b.age;
	else
	{
		int s=strcmp(a.name,b.name);
		return s<0;
	}	
} 

int main()
{
	int n,k;
	scanf("%d %d",&n,&k);
	
	for(int i=0;i<n;i++)
		scanf("%s%d%d",rec[i].name,&rec[i].age,&rec[i].worth);
	
	//第一次排序,按照age排 
	sort(rec,rec+n,cmp1);
	
	for(int i=1;i<=k;i++)
	{
		int print,min,max;
		scanf("%d%d%d",&print,&min,&max);
		printf("Case #%d:\n",i);
		
		//寻找age范围在rec中的位置
		int start=-1,end=-1; 
		for(int j=0;j<n;j++)
			if(start<0&&rec[j].age>=min)
			{
				start =j;
				break;
			}
		for(int j=n-1;j>=0;j--)
			if(end<0&&rec[j].age<=max)
			{
				end = j;
				break;
			}	
				
		//如果范围内没人 
		if(start>end)
		{
			printf("None\n");
			continue;
		}
		
		int t0=0;
		for(int t=start;t<=end;t++)
		{
			temp[t0]=rec[t];
			t0++;
		}
		//第二次排序 
		sort(temp,temp+t0,cmp2);
		
		int t=0;
		while(t<t0&&t+1<=print)
		{
			printf("%s %d %d\n",temp[t].name,temp[t].age,temp[t].worth);
			t++;
		}
		
	}
	
	return 0;
}






以下是满分代码:

#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int maxn = 100010;
struct Record{
	char name[10];
	int age;
	int worth;
}rec[maxn],temp[maxn];
int Age[maxn]={0};

bool cmp(Record a,Record b)
{
	if(a.worth!=b.worth)
		return a.worth>b.worth;
	else if(a.age!=b.age)
		return a.age<b.age;
	else
	{
		int s=strcmp(a.name,b.name);
		return s<0;
	}
}

int main()
{
	int n,k;
	scanf("%d%d",&n,&k);
	
	for(int i=0;i<n;i++)
		scanf("%s%d%d",rec[i].name,&rec[i].age,&rec[i].worth);
		
	sort(rec,rec+n,cmp);
	
	//把每个年龄段里最有钱的放在数组里
	int isvalue=0;
	for(int i=0;i<n;i++)
	{
		if(Age[rec[i].age]<100)
		{
			Age[rec[i].age]++;
			temp[isvalue++]=rec[i];	
		}	
	} 
	
	for(int i=1;i<=k;i++)
	{
		int print,max,min,isprint=0;
		scanf("%d%d%d",&print,&min,&max);
		printf("Case #%d:\n",i);
		for(int j=0;j<isvalue;j++)
		{
			if(temp[j].age>=min&&temp[j].age<=max)
			{
				printf("%s %d %d\n",temp[j].name,temp[j].age,temp[j].worth);
				isprint++;
			}
			if(isprint>=print)
					break;
		}
		if(isprint==0)
			printf("None\n");
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值