攻破算法题_排序_PAT_A1055_The World‘s Richest (25)

题目:

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

输入格式:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10​5​​) - the total number of people, and K (≤10​3​​) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10​6​​,10​6​​]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

输出格式:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

输入样例 1:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

输出样例 1:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题目分析:

  • 排序规则
  • 按资产从大到小排列
    若资产相同,按年龄从小到大排列
    若资产和年龄都相同,按字母表顺序从小到大排列
  • 每次查询结果的输出都有限制人数k,限制的年龄[Amin,Amax]

算法思路:

1.定义结构体
struct Person{
char name[10];
int age;
int worth;
}ps[maxn],vaild[maxn];
2.输入每个人的姓名,年龄,资产
3.按排序规则编写排序函数
4.定义数组Age[maxn],表示一个年龄排名前M位的人,在M位以后都不能输出
注意点:
年龄在[Amin,Amax]之间,可能一个年龄存在着多位富豪,要排除一些不符合要求的(年龄大于>100)

C++实现

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>

using namespace std;

const int MAXN = 100010;

int Age[MAXN] = {0};		//某一年龄的人数
struct Person{
	char name[10];			//姓名
	int age;				//年龄
	int worth;				//资产
}ps[MAXN], vaild[MAXN];

bool cmp(Person a, Person b) { 			//按排序规则编写排序函数
	if(a.worth != b.worth) { 			//按资产从大到小排
		return a.worth > b.worth;
	} 
	else if(a.age != b.age) { 			//若资产相同,按年龄从小到大排
		return a.age < b.age;
	}
	else { 								//若资产和年龄都相同,按字母表的顺序从小到大排
		return strcmp(a.name,b.name) < 0;
	}
}

int main() {
	int n, query, vaildNum = 0;
	scanf("%d %d", &n, &query);
	for(int i = 0; i < n; ++i) { 		//输出每个人的信息
		scanf("%s %d %d", ps[i].name, &ps[i].age, &ps[i].worth);
	}
	sort(ps, ps + n, cmp);
	for(int i = 0; i < n; ++i) { 		//把符合条件的人放入vaild中,之后都操作这个数组
		if(ps[i].age <= 100) {
			Age[ps[i].age]++; 			//该年龄的人数+1
			vaild[vaildNum++] = ps[i];
		}
	}
	int m, Amin, Amax;
	for(int i = 1; i <= query; ++i) {		//进行query次测试
		scanf("%d %d %d", &m, &Amin, &Amax); //输入规定人数,年龄段
		printf("Case #%d:\n", i);
		int printNum = 0;
		for(int j = 0; j < vaildNum && printNum < m; ++j) { 	//遍历valid数组,输出符合的数据
			if(vaild[j].age >= Amin && vaild[j].age <= Amax) {
				printf("%s %d %d\n", vaild[j].name, vaild[j].age, vaild[j].worth);
				printNum++;
			}
		}
		if(printNum == 0) {
			printf("None\n");
		}
	}

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值