PAT 甲级 1001  A+B Format

1001 A+B Format (20 point(s))

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

Experiential Summing-up 

this question....emmmm,I did cost a bit time to consider it . Mainly because I want to use string to cope with it . But it's complex to solve it by string type than using char array. So I did't find a better method until I refer to my last submit code. I find it so easy to format a ten size char array to process data. Certainly, we must handle two special cases which include when sum is equal to zero and when sum is negative number. There is nothing problem except what is said above. That's all~~╭(′▽`)╭(′▽`)╯

(The purpose of using English to portray my solution is that to exercise the ability of my expression of English and accommodate PAT advanced level's style.We can make progress together by reading and comprehending it. Please forgive my basic grammar's and word's error. Of course, I would appreciated it if you can point out my grammar's and word's error in comment section.( •̀∀•́ ) Furthermore, Big Lao please don't laugh at me because I just a English beginner settle for CET6    _(:з」∠)_  )

Accepted Code

#include <cstdio>

int main()
{
	int a,b;
	scanf("%d %d",&a,&b);
	int sum=a+b;
	char s[10];
	int len=0,x=0;
	if(sum==0)
		printf("0\n");
	else
	{
		if(sum<0)
			printf("-");
		sum=sum>0?sum:-sum;
		while(sum)
		{
			if(x!=0&&x%3==0)
				s[len++]=',';
			s[len++]=sum%10+'0';
			sum/=10;
			++x;
		}
		for(int i=len-1;i>=0;--i)
			printf("%c",s[i]);
		printf("\n");
	}
	return 0;
}

 

  • 5
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 16
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 16
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值