PAT (Advanced Level) Practice 1001 A+B Format

目录

题目标题

题目描述

输入描述

输出描述

输入样例

输出样例

思路描述

Code

提交结果


题目标题

1001 A+B Format

题目描述

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).


输入描述

Each input file contains one test case. Each case contains a pair of integers a and b where −10^6≤a,b≤10^6. The numbers are separated by a space.


输出描述

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.


输入样例

-1000000 9


输出样例

-999,991


思路描述

从后往前数,每三个数字以一个','分开,同时注意,数字首部不能有逗号,如果是‘-’,数字的len需要减一。


Code

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int a,b;
    cin>>a>>b;
    int sum=a+b;
    string s=to_string(sum);
    int count=1;
    reverse(s.begin(),s.end());
    string t="";
    int i=0;
    int len=s.length();
    if(s[s.length()-1]=='-')
        len--;
    for(i;i<len;i++)
    {
        t+=s[i];
        if(count%3==0&&count!=len)
            t+=",";
        count++;
    }
    if(len!=s.length())
        t+="-";
    reverse(t.begin(),t.end());
    cout<<t<<endl;
    return 0;
}

提交结果


freetalk or label

easy

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值