PAT 甲级 1103  Integer Factorization

1103 Integer Factorization (30 point(s))

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12​2​​+4​2​​+2​2​​+2​2​​+1​2​​, or 11​2​​+6​2​​+2​2​​+2​2​​+2​2​​, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a​1​​,a​2​​,⋯,a​K​​ } is said to be larger than { b​1​​,b​2​​,⋯,b​K​​ } if there exists 1≤L≤K such that a​i​​=b​i​​ for i<L and a​L​​>b​L​​.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

经验总结:

少有的DFS作为最后一大题。这一题,如果弄清楚思路,不是太难,没有思路的话,就很困难了,可能根本就没想到需要用DFS来解。首先,应该将所有可能的因子计算出来,然后对于所有可能的因子,从大到小进行DFS,每一次DFS都有两个分支,选择这个因子或者不选这个因子,改变相应参数,注意,必须先选后不选(因为是要找到题目要求的更大的序列),然后设计好递归出口,还是很经典的DFS,就是自己没有思路= =  学习到了。

AC代码

#include <cstdio>
#include <vector>
#include <queue>
#include <cmath>
#include <algorithm>
using namespace std;
int n,p,k,maxsum=-1;
vector<int> fac,ans,temp;
void DFS(int index,int nowK,int sum,int facsum)
{
	if(sum>n||nowK>k||index==0)
		return ;
	if(sum==n&&nowK==k)
	{
		if(facsum>maxsum)
		{
			maxsum=facsum;
			ans=temp;
		}
		return ;
	}
	temp.push_back(index);
	DFS(index,nowK+1,sum+fac[index],facsum+index);
	temp.pop_back();
	DFS(index-1,nowK,sum,facsum);
}
int power(int x)
{
	int ans=1;
	for(int i=0;i<p;++i)
		ans*=x;
	return ans;
}
int main()
{
	scanf("%d%d%d",&n,&k,&p);
	for(int i=0;i<=n;++i)
	{
		int pro=power(i);
		if(pro<=n)
			fac.push_back(pro);
		else
			break;
	}
	DFS(fac.size()-1,0,0,0);
	if(maxsum==-1)
		printf("Impossible\n");
	else
	{
		printf("%d = %d^%d",n,ans[0],p);
		for(int i=1;i<ans.size();++i)
			printf(" + %d^%d",ans[i],p);
		printf("\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值