6114 Problem A Course List for Student (25)

问题 A: Course List for Student (25)

时间限制: 1 Sec  内存限制: 32 MB
 

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

输入

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

输出

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

样例输入

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

样例输出

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

经验总结

这一题.....最主要的就是,一定不能用map<string, vector<int> >这种STL映射,但根本原因不在于此,而在于,不能用cin 和cout 进行IO,否则会超时,不过使用map<int ,int> 可以,当然,直接将学生姓名一一映射为整数然后利用一位数组的方法更快一些~

AC代码

#include <cstdio>
#include <string>
#include <cstring>
#include <vector>
#include <algorithm>
#include <iostream>
#include <map>
using namespace std;
const int maxn=26*26*26*10+1;
vector<int> stu[maxn];
int compute(char a[])
{
	int id=0;
	for(int i=0;i<3;++i)
		id=id*26+(a[i]-'A');
	id=id*10+(a[3]-'0');
	return id;
}
int main()
{
	int n,m,no,x;
	scanf("%d %d",&m,&n);
	char name[6];
	for(int i=0;i<n;++i)
	{
		scanf("%d %d",&no,&x);
		for(int j=0;j<x;++j)
		{
			scanf("%s",name);
			int res=compute(name);
			stu[res].push_back(no);
		}
	}
	for(int i=0;i<m;++i)
	{
		scanf("%s",name);
		printf("%s",name);
		int res=compute(name);
		if(stu[res].size()==0)
		{
			printf(" 0\n");
		}
		else
		{
			sort(stu[res].begin(),stu[res].end());
			printf(" %d",stu[res].size());
			for(int j=0;j<stu[res].size();++j)
				printf(" %d",stu[res][j]);
			printf("\n");
		}
	}
    return 0;
}

 

  • 4
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值