【OJ】Course List for Student——时间超时以及内存超时

Course List for Student 

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

输入

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

输出

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

样例输入

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

样例输出

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

这是我原先的代码,使用string实现,但是出现时间超时,是因为最后一组测试数据比较庞大,使用map或者string会导致超时。

#include <iostream>
#include <vector>
#include <string>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
struct course{
    int index;
    int Nofstu;
    vector<string> stu;
};
struct student{
    int coursenum;
    vector<int> course;
    string name;
};
bool cmp(course a,course b){
return a.index<b.index;}
int main()
{
    int n,k;
    cin>>n>>k;
    course *c=new course[k];
    student *s=new student[n];
    for(int i=0;i<k;i++){
        cin>>c[i].index>>c[i].Nofstu;
        for(int j=0;j<c[i].Nofstu;j++){
            string temp;
            cin>>temp;
            c[i].stu.push_back(temp);
        }
    }
    sort(c,c+k,cmp);
    for(int i=0;i<n;i++){
        cin>>s[i].name;
        s[i].coursenum=0;
        for(int j=0;j<k;j++){
            for(int u=0;u<c[j].Nofstu;u++){
                if(c[j].stu[u]==s[i].name){
                    s[i].coursenum+=1;
                    s[i].course.push_back(c[j].index);
                    break;
                }
            }
        }
        cout<<s[i].name<<' '<<s[i].coursenum<<' ';
        for(int j=0;j<s[i].coursenum;j++){
            cout<<s[i].course[j];
            if(j!=s[i].coursenum-1)cout<<' ';
            else cout<<endl;
        }
    }

    return 0;
}

所以答案提供了一种可以避免string的方法

使用hash,由于名字的特殊性,可以使用hash用数字唯一的表示一个名字

并且我的代码考虑的太简单的,一开始输入的时候就可以直接建立一个hash空间大小的 存储每一个hashint对应名字所在班级的班级号的vector 然后排序输出.

AC代码:

#include <iostream>
#include <vector>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
int getID(char name[]){
    int ID=0;
    for(int i=0;i<3;i++)ID=ID*26+name[i]-'A';
    ID=ID*10+(name[3]-'0');
    return ID;
}
const int N=40005;
const int M=26*26*26*10+1;
vector<int> selectCourse[M];

int main(){
    char name[5];
    int n,k;
    scanf("%d%d",&n,&k);
    for(int i=0;i<k;i++){
        int index,num;
        scanf("%d%d",&index,&num);
        for(int j=0;j<num;j++){
            scanf("%s",name);
            selectCourse[getID(name)].push_back(index);
        }
    }
    for(int i=0;i<n;i++){
        scanf("%s",name);
        int id=getID(name);
        sort(selectCourse[id].begin(),selectCourse[id].end());
        printf("%s %d",name,selectCourse[id].size());
        for(int j=0;j<selectCourse[id].size();j++){
            printf(" %d",selectCourse[id][j]);
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值