HDU——2609How many(字符串的最小表示法+substr)

80 篇文章 1 订阅
20 篇文章 0 订阅

 

How many

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1852    Accepted Submission(s): 763


Problem Description
Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.
 

Input
The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').
 

Output
For each test case output a integer , how many different necklaces.
 

Sample Input
  
  
4 0110 1100 1001 0011 4 1010 0101 1000 0001
 

Sample Output
  
  
1 2
 

题意:输入n串二进制的字符串,将其看成项链,问有多少种项链,第一次WA了发现并不是直接map就可以做的,还要将字符串先转换成一种统一的,比如abcde(为了方便表示就用字母了)与cdeab是一样的,相当于把这串字符串头尾连起来,从不同的视角看过去就显示不一样了,那重点就是把这些不同角度的项链统一成一个角度的。按照最小字典序进行统一。最小表示法的模版是网上找的,但是这个模版只能返回一个开始位置整数,拿来修改了一下就可以了。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
#include<set>
#include<map>
#include<sstream>
#include<algorithm>
#include<cmath>
#include<cstdlib>
using namespace std;
string zxc(string s,const int &l)
{
    int i = 0, j = 1, k = 0, t;
    while(i < l && j < l && k < l) 
    {
        t = s[(i + k) >= l ? i + k - l : i + k] - s[(j + k) >= l ? j + k - l : j + k];
        if(!t) k++;
        else
        {
            if(t > 0) i = i + k + 1;
            else j = j + k + 1;
            if(i == j) ++ j;
            k = 0;
        }
    }
    int q=min(i,j);//这里本要返回q(最小表示的起始位置),这里先利用一下
    s+=s;//首先要把字符串自增一下
    s=s.substr(q,l);//(起始位置,原来长度)
    return s;//返回最小表示的字符串
}
int main (void)
{
    string s;
    int t,n;
    while (cin>>n)
    {
        map<string,int>list;//无脑map开始了......
        for (int i=0; i<n; i++)
        {
            cin>>s;
            list[zxc(s,s.size())]=0;
        }
        cout<<list.size()<<endl;
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值