hdu2609——最大最小表示法妙用+set

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2609
Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.

Input

The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').

Output

For each test case output a integer , how many different necklaces.

Sample Input

4
0110
1100
1001
0011
4
1010
0101
1000
0001

Sample Output

1
2

给你n(n<10000)项链,项链的长度不会超过100条,告诉我‎
‎有多少种项链。(如果两条项链可以旋转相等,我们说两条项链是一些)。‎
‎例如 0110 表示项链,您可以旋转它。0110 -> 1100 -> 1001 -> 0011->0110。‎

‎输入‎

‎输入包含多个测试用例。‎
‎每个测试用例包括:第一个整数 n. (2_lt;\n\lt;#10000)‎
‎下一个 n 行。每行都有一个长度相等的字符串。(字符串仅包含"0","1")。‎

‎输出‎

‎对于每个测试用例输出一个整数,有多少不同的项链。

 

这个题其实不难想到怎么做,最简单的方法就是用最小表示法+set去重,

对每个字符串求出最小表示的位置,因为是环状的,字符串就是从0,到最小位置的子串合并上从最小位置到len的子串

#include <bits/stdc++.h>
using namespace std;
string s;
int min_pos(int len){
    int i=0,j=1,k=0;
    while(i<len&&j<len&&k<len){
        int pan=s[(i+k)%len]-s[(j+k)%len];
        if(!pan)
            k++;
        else{
            if(pan>0)
                i+=k+1;
            else
                j+=k+1;
            if(i==j)
                j++;
            k=0;
        }
    }
    return min(i+1,j+1);
}
int main(int argc, char** argv) {
	int n;
	while(cin>>n){
		set<string> a;
		for(int i=0;i<n;++i){
			cin>>s;
			int len=s.size();
			a.insert(s.substr(min_pos(len),len)+s.substr(0,min_pos(len)));
		}
		cout<<a.size()<<endl;
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值