杭电1016

博主第一次搜索,,自力更生的AC掉了;(小小的借鉴了下其他大牛的)
<h1 style="color: rgb(26, 92, 200);">Prime Ring Problem</h1><span size="+0"><strong><span style="font-family:Arial;font-size:12px;color:green;font-weight: bold;">Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29228    Accepted Submission(s): 13018
</span></strong></span>

<div class="panel_title" align="left">Problem Description</div><div class="panel_content">A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

<img src="http://acm.hdu.edu.cn/data/images/1016-1.gif" alt="" />
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Input</div><div class="panel_content">n (0 < n < 20).
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Output</div><div class="panel_content">The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Sample Input</div><div class="panel_content"><pre><div style="font-family: Courier New,Courier,monospace;">6
8</div>

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 
#include <iostream>
#include <cstring>
using namespace std;
int vis[40];
int num[40];
int n,temp;
int prime(int x)
{
    int i;
    for(i=2;i<x;i++)
    {
        if(x%i==0)
        {
            return 0;
        }
    }
    return 1;
}
void bfs(int xx)
{
    if(temp == n&&prime(xx+1))
    {
        for(int i=1;i<n;i++)
        {
            cout<<num[i]<<" ";
        }
        cout<<num[n]<<endl;
    }
    else
    {
        for(int i=1;i<=n;i++)
        {
            if(vis[i]==0&&prime(i+xx))
            {
                num[++temp]=i;
                vis[i]=1;
                bfs(i);
                vis[i]=0;
                temp--;
            }
        }
    }
}
int main()
{
    int i=0;
    while(cin>>n)
    {

        temp=1;
        memset(vis,0,sizeof(vis));
        vis[1]=1;
        num[1]=1;
        cout<<"Case "<<++i<<":"<<endl;
        bfs(1);
        cout<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值