UVa 548 - Tree【二叉树的递归遍历(DFS)】

548 - Tree

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.

Input 

The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node.

Output 

For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input 

3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255

Sample Output 

1
3
255

 

用数组保存二叉树,并用递归完成二叉树的深度优先搜索(DFS)。

#include<iostream>
#include<cstring>
#include<sstream>
#include<algorithm>
using namespace std;
//因为各个节点的权值各不相同且都是正整数,直接用权值作为节点编号
const int maxn=10010;
int in_order[maxn],post_order[maxn],lch[maxn],rch[maxn];
int n;
bool read_list(int *a){
    string line;
    if(!getline(cin,line)) return false;
    stringstream ss(line);
    int x;
    n=0;
    while(ss>>x)a[n++]=x;
    return true;
}
//把中序和后序简称一棵二叉树,返回树根,用数组存二叉树
int build(int L1,int R1,int L2,int R2){
    if(L1>R1) return 0;//空树
    int root=post_order[R2];
    int p=L1;
    while(in_order[p]!=root) p++;
    int cnt=p-L1;//左子树的节点个数
    lch[root]=build(L1,p-1,L2,L2+cnt-1);
    rch[root]=build(p+1,R1,L2+cnt,R2-1);
    return root;
}
int best,best_sum;//目前为止找到的最优解和对应的权值和
//递归,深度优先遍历
void dfs(int u,int sum){
    sum+=u;
    if(!lch[u]&&!rch[u]){//叶子
        if(sum<best_sum||(sum==best_sum&&best>u)){
            best=u;
            best_sum=sum;
        }
    }
    if(lch[u]) dfs(lch[u],sum);
    if(rch[u]) dfs(rch[u],sum);
}
int main()
{
    while(read_list(in_order)){
        read_list(post_order);
        build(0,n-1,0,n-1);
        /*for(int i=0;i<10;i++)
            cout<<lch[i]<<" ";
        cout<<endl;
        for(int i=0;i<10;i++)
            cout<<rch[i]<<" ";
        cout<<endl<<endl;*/
        best_sum=1000000000;
        dfs(post_order[n-1],0);
        cout<<best<<endl;
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值