SDNU 1143.Ivan comes again!【山东省第一届ACM】【7月21】

Ivan comes again!

Description

The Fairy Ivan gave Saya three problems to solve (Problem F). After Saya finished the first problem (Problem H), here comes the second.
This is the enhanced version of Problem H.
There is a large matrix whose row and column are less than or equal to 1000000000. And there are three operations for the matrix:
1)     add: Mark an element in the matrix. The element wasn’t marked before it is marked.
2)     remove: Delete an element’s mark. The element was marked before the element’s mark is deleted.
3)     find: Show an element’s row and column, and return a marked element’s row and column, where the marked element’s row and column are larger than the showed element’s row and column respectively. If there are multiple solutions, return the element whose row is the smallest; and if there are still multiple solutions, return the element whose column is the smallest. If there is no solution, return -1.
Of course, Saya comes to you for help again.

Input

The input consists of several test cases.
The first line of input in each test case contains one integer N (0<N≤200000), which represents the number of operations.
Each of the next N lines containing an operation, as described above.
The last case is followed by a line containing one zero.

Output

For each case, print the case number (1, 2 …) first. Then, for each “ find” operation, output the result. Your output format should imitate the sample output. Print a blank line after each test case.

Sample Input

4
add 2 3
find 1 2
remove 2 3
find 1 2

0

Sample Output

Case 1:
2 3
-1
继续省赛题。题目大意:
add:添加该点
find:找横纵坐标都大于该点的最小的点
remove:删除该点
模拟就好~~用set<pair<int,int> >存。代码贴上:
#include<cstdio>
#include<string>
#include<set>;
using namespace std;
pair<int,int>pai;//放在set里
int main(){
    int n,kase=0;
    while(scanf("%d",&n)==1&&n){
        printf("Case %d:\n",++kase);
        set<pair<int,int> >f;
        char x[7];
        while(n--){
            scanf("%s",x);
            scanf("%d%d",&pai.first,&pai.second);
            if(x[0]=='a')
                f.insert(pai);
            else if(x[0]=='r')
                f.erase(pai);
            else{//这是难点
                set<pair<int,int> >::iterator it=f.lower_bound(pai);//lower_bound()返回指向大于(或等于)某值的第一个元素的迭代器
                for(;it!=f.end();it++){
                    if(it->first>pai.first&&it->second>pai.second){
                        printf("%d %d\n",it->first,it->second);
                        break;//这么重要的语句竟然忘了!!!!!找到一个点就可以退出来了····
                    }
                }
                if(it==f.end())
                    printf("-1\n");
            }
        }
    printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值