HDU 1024.Max Sum Plus Plus【动态规划】【11月14】

Max Sum Plus Plus

Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
  
  
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
m个不交叉子序列和值最大。

这个我可能解释不清楚,附上各种解题思路:

http://blog.csdn.net/juststeps/article/details/8687369
http://www.cnblogs.com/kuangbin/archive/2011/08/04/2127085.html
http://blog.sina.com.cn/s/blog_677a3eb30100jxqa.html
http://www.xuebuyuan.com/1410276.html
http://blog.csdn.net/acm_davidcn/article/details/5887401
http://www.cnblogs.com/wally/archive/2013/03/13/2957061.html
http://blog.csdn.net/xymscau/article/details/6857311
http://m.blog.csdn.net/blog/kay_zhyu/8727993
http://blog.csdn.net/zhanglei0107/article/details/7423419

// 状态:dp[i][j]表示以j结尾的i个子段和的最优解
// 转移:dp[i][j] = max{dp[i][j-1],max{dp[i-1][t]}}+a[j];
// 第j个数字要么作为新的起点加入队列,要么直接加到前一段里
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <algorithm>
using namespace std;
const int MAXN = 1000000 + 10;
int s[MAXN], DP[MAXN], pre[MAXN], n, m;
int main()
{
    while(scanf("%d%d", &m, &n) != EOF)
    {
        memset(DP, 0, sizeof(DP));
        memset(pre, 0, sizeof(pre));
        for(int i = 1; i <= n; i ++)    scanf("%d", &s[i]);
        int ans;
        for(int i = 1; i <= m; i ++)
        {
            ans = -(1 << 31);
            for(int j = i;j <= n; j ++)
            {
                DP[j] = max(DP[j - 1] + s[j], pre[j - 1] + s[j]);
                // 保存局部最优解
                pre[j - 1] = ans;
                ans = max(ans, DP[j]);
            }
        }
        cout << ans << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,HDU1622是一道关于二叉树的题目,要求读入一系列二叉树的节点信息,输出它们的层序遍历结果。如果输入的二叉树不完整或存在重复节点,则输出"not complete"。下面是Java的实现代码: ```java import java.util.LinkedList; import java.util.Queue; import java.util.Scanner; public class Main { static class Node { int val; Node left, right; public Node(int val) { this.val = val; } } public static void main(String[] args) { Scanner sc = new Scanner(System.in); while (sc.hasNext()) { String s = sc.nextLine(); if (s.isEmpty()) { continue; } String[] nodes = s.split("\\s+"); Node root = new Node(Integer.parseInt(nodes[0].substring(1))); Queue<Node> queue = new LinkedList<>(); queue.offer(root); boolean isComplete = true; for (int i = 1; i < nodes.length - 1; i += 2) { Node cur = queue.poll(); if (!nodes[i].equals("()")) { cur.left = new Node(Integer.parseInt(nodes[i].substring(1))); queue.offer(cur.left); } else { isComplete = false; } if (!nodes[i + 1].equals("()")) { cur.right = new Node(Integer.parseInt(nodes[i + 1].substring(0, nodes[i + 1].length() - 1))); queue.offer(cur.right); } else { isComplete = false; } } if (!isComplete) { System.out.println("not complete"); continue; } StringBuilder sb = new StringBuilder(); queue.offer(root); while (!queue.isEmpty()) { Node cur = queue.poll(); sb.append(cur.val).append(" "); if (cur.left != null) { queue.offer(cur.left); } if (cur.right != null) { queue.offer(cur.right); } } System.out.println(sb.toString().trim()); } } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值