Ball
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 775 Accepted Submission(s): 463
Problem Description
ZZX has a sequence of boxes numbered
1,2,...,n
. Each box can contain at most one ball.
You are given the initial configuration of the balls. For 1≤i≤n , if the i -th box is empty then a[i]=0 , otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.
He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)
He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
You are given the initial configuration of the balls. For 1≤i≤n , if the i -th box is empty then a[i]=0 , otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.
He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)
He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
Input
First line contains an integer t. Then t testcases follow.
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].
1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.
0<=a[i],b[i]<=n.
1<=l[i]<=r[i]<=n.
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].
1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.
0<=a[i],b[i]<=n.
1<=l[i]<=r[i]<=n.
Output
For each testcase, print "Yes" or "No" in a line.
Sample Input
5 4 1 0 0 1 1 0 1 1 1 1 4 4 1 0 0 1 1 0 0 2 2 1 4 4 2 1 0 0 0 0 0 0 1 1 3 3 4 4 2 1 0 0 0 0 0 0 1 3 4 1 3 5 2 1 1 2 2 0 2 2 1 1 0 1 3 2 4
Sample Output
No No Yes No Yes
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int MAX = 1005;
struct ss
{
int num, id;
ss()
{
id = 10010;
}
}a[MAX];
bool cmp(ss a, ss b)
{
return a.id < b.id;
}
int b[MAX], vis[MAX];
int T, N, M, l, r;
int main()
{
scanf("%d", &T);
while(T--)
{
memset(vis, 0, sizeof(vis));
scanf("%d %d", &N, &M);
for(int i = 1;i <= N; ++i) scanf("%d", &a[i].num);
for(int i = 1;i <= N; ++i) scanf("%d", &b[i]);
for(int i = 1;i <= N; ++i)
for(int j = 1;j <= N; ++j)
{
if(a[i].num == b[j] && !vis[j])
{
a[i].id = j;
vis[j] = 1;
break;
}
}
for(int i = 0;i < M; ++i)
{
scanf("%d %d", &l, &r);
sort(a+l, a+r+1, cmp);
}
bool key = true;
for(int i = 1;i <= N; ++i)
{
if(a[i].num != b[i])
{
key = false;
cout <<"No"<< endl;
break;
}
}
if(key) cout <<"Yes"<< endl;
}
return 0;
}