Space Elevator(多重背包)

Problem Description
The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.
 

Input
* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.
 

Output
* Line 1: A single integer H, the maximum height of a tower that can be built
 

Sample Input
  
  
3 7 40 3 5 23 8 2 52 6
 

Sample Output
  
  
48
 
/*题意:有一群牛要上太空,他们计划建一个太空梯(用一些石头垒),他们有k种不同类型的石头,每一种石头的高度
为h,数量为c,由于会受到太空辐射,每一种石头不能超过这种石头的最大建造高度a,求解利用这些石头所能修建的
太空梯的最高的高度.多重背包问题,与一般的多重背包问题所不同的知识多了一个限制条件就是某些"物品"叠加
起来的"高度"不能超过一个值,于是我们可以对他们的最高可能达到高度进行排序,然后就是一般的多重背包问题了
*/
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int dp[60000],k[60000];
struct node
{
    int h,c,a;
}m[60000];
int n;
int cmp(node x,node y)
{
    return x.a<y.a;
}
int main()
{
   while(cin>>n)
   {

       for(int i=1;i<=n;i++)
       {
           cin>>m[i].h>>m[i].a>>m[i].c;
       }
       sort(m+1,m+n+1,cmp);
       memset(dp,0,sizeof(dp));
       dp[0]=1;
       int ans=0;
       for(int i=1;i<=n;i++)
        {
            memset(k,0,sizeof(k));
           for(int j=m[i].h;j<=m[i].a;j++)
           {
               if(!dp[j]&&dp[j-m[i].h]&&m[i].c>k[j-m[i].h])
               {
                   dp[j]=1;
                   k[j]=k[j-m[i].h]+1;
                   if(j>ans)ans=j;
               }
           }
        }
        cout<<ans<<endl;
   }
   return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值