poj2392

Space Elevator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5418 Accepted: 2511

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48




#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct BLOCKS
{
    int h,a,c;
};
BLOCKS blocks[400+1];
int dp[40000+1];
int num[40000+1];
bool cmp(const BLOCKS&b1,const BLOCKS&b2)
{
    return b1.a<b2.a;
}
void init(int n)
{
    for(int i=1;i<=n;i++)
    {
        cin>>blocks[i].h>>blocks[i].a>>blocks[i].c;
    }
    memset(dp,0,sizeof(dp));
    dp[0]=1;
    sort(blocks+1,blocks+n+1,cmp);
}
void cal(int n)
{
    for(int i=1;i<=n;i++)
    {
        memset(num,0,sizeof(num));
        for(int j=blocks[i].h;j<=blocks[i].a;j++)
        {
            if(!dp[j]&&dp[j-blocks[i].h]&&num[j-blocks[i].h]<blocks[i].c)
            {
                dp[j]=1;
                num[j]=num[j-blocks[i].h]+1;
            }
        }
    }
    int m=blocks[n].a;
    while(!dp[m])m--;
    cout<<m<<endl;
}
int main()
{
    int n;
    cin>>n;
    init(n);
    cal(n);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值