入门练习-贪心(3)POJ-3253栅栏维修

Fence Repair POJ - 3253
Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input
Line 1: One integer N, the number of planks
Lines 2… N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
Sample Input
3
8
5
8
Sample Output
34
Hint
He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
大意:
题目:
农夫约翰为了修理栅栏,要将一块很长的木板分割成N块。准备切成的木板的长度为L1、L2、……、Ln. 未切割木板的长度恰好为切割木板的长度和。每次切断木板时,需要的开销为这块木板的长度。例如,长度为21的木板切割成5、8、8的三块木板。长为21的木板切割成13、8时,开销为21.再将长度为13的木板切割成长度5、8时,开销为13.于是合计开销为34。于是按题目要求将木板切割完,最小的开销是多少?

限制条件:
1<=N<=2000
0<=Li<=5000

输入样例:
N=3, L={8, 5, 8}
输出样例:
34
解答:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#define MAX_N 20000

using namespace std;

int n,a[MAX_N];

int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)
		scanf("%d",&a[i]);
	int i=0;
	double ans=0;
	while(n>1){
			int mil1=0,mil2=1,i;
			if(a[mil1]>a[mil2])
			swap(a[mil1],a[mil2]);
			for(i=2;i<n;i++)
			if(a[i]<a[mil1]){
			mil2=mil1;
			mil1=i;
			}
			else
			if(a[i]<a[mil2])
			mil2=i;
			int t;
			t=a[mil1]+a[mil2];
			ans+=t;
			if(mil1==n-1) swap(mil1,mil2);
			a[mil1]=t;
			a[mil2]=a[n-1];
			n--;
		}
		
		printf("%.0lf\n",ans);
	return 0;
}

优先队列做法:

#include <iostream>
#include <queue>

using namespace std;

const long long maxn = 20000+100;
priority_queue<long long>Q;
long long a[maxn];

int main()
{
    long long n;
    cin>>n;
    for(long long i=0;i<n;i++)
    {
        cin>>a[i];
        Q.push(-a[i]);
    }
    long long sum=0;
    for(long long i=1;i<n;i++)
    {
        long long k = Q.top();
        Q.pop();
        k+=Q.top();
        Q.pop();
        Q.push(k);
        sum-=k;
    }
    cout<<sum;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值