HDU 1892 See you~(经典二维树状数组)

Problem Description
Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year.
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles.
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position.

Input
In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed.
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries.
There are 4 kind of queries, sum, add, delete and move.
For example:
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points.
A x1 y1 n1 means I put n1 books on the position (x1,y1)
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them.
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them.
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100.

Output
At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries.
For each "S" query, just print out the total number of books in that area.

Sample Input
  
  
2 3 S 1 1 1 1 A 1 1 2 S 1 1 1 1 3 S 1 1 1 1 A 1 1 2 S 1 1 1 2

Sample Output
  
  
Case 1: 1 3 Case 2: 1 4
题目大意:房间里有很多方格,每个方格开始放一本书。建一个坐标系。输入坐标(方格坐标)查询(x1,y1)到(x2,y2)之间的书本总数,还可以增加某个方格里面的书本,减少某个方格里的书本( 如果不够减,则全部减掉)。还可以把(x1,y1)中的书本拿到(x2,y2)中。如果不够拿,则全部拿走。这一切都是动态的,经典的二维树状数组。
但是想AC真的不容易。各种WA RUNTIME error...最后AC...
注意:要把每个方格的书本纪录下来。这个不解释了。其他细节见AC代码:
#include<stdio.h>
#include<string.h>
#define MAX 1005
#define max(a,b) a>b ? a:b
#define min(a,b) a>b ? b:a
int c[MAX][MAX];
int a[MAX][MAX];                    //记录每个格子里面的书
int lowbit(int x)
{
    return x&(-x);
}
void updata(int x,int y,int d)
{
    for(int i=x;i<MAX;i=i+lowbit(i))
        for(int j=y;j<MAX;j=j+lowbit(j))
        c[i][j]=c[i][j]+d;
}
int getsum(int x,int y)
{
    int res = 0;
    for(int i=x;i>0;i=i-lowbit(i))
        for(int j=y;j>0;j=j-lowbit(j))
        res=res+c[i][j];
    return res;
}
int main()
{
    int t,n,i,j;
    char s[10];
    int x1,y1,x2,y2,n1;
    int xmax,xmin,ymax,ymin;
    int ans,k=0;
    scanf("%d",&t);
    while(t--)
    {
        k++;
        printf("Case %d:\n",k);
        ans=0;
        memset(c,0,sizeof(c));
        scanf("%d",&n);
        for(i=1;i<MAX;i++)          //注意数组是否越界...开始写出i<=MAX RUNTIME error 好几次.查了好久
        {
            for(j=1;j<MAX;j++)
            {
             a[i][j]=1;             //每个格子一本书
             updata(i,j,1);
            }
        }
        while(n--)
        {
            scanf("%s",s);
            if(s[0]=='S')
            {    //这里必须排序
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                x1++;y1++;x2++;y2++;            //树状数组下标从1 开始.下面一样
                xmax=max(x1,x2);xmin=min(x1,x2);ymax=max(y1,y2);ymin=min(y1,y2);
                ans=getsum(xmax,ymax)+getsum(xmin-1,ymin-1)-getsum(xmax,ymin-1)-getsum(xmin-1,ymax);
                printf("%d\n",ans);
            }
            if(s[0]=='A')
            {
                scanf("%d%d%d",&x1,&y1,&n1);
                x1++;y1++;
                updata(x1,y1,n1);
                a[x1][y1]=a[x1][y1]+n1;        //记录剩下的书
            }
            if(s[0]=='D')
            {
                scanf("%d%d%d",&x1,&y1,&n1);
                x1++;y1++;
                if(n1>=a[x1][y1])                //从x1,y1中拿走n1本书
                {                                //如果不够,则全部拿走
                    updata(x1,y1,-a[x1][y1]);
                    a[x1][y1]=0;                //记录剩下的书
                }
                else
                {
                    updata(x1,y1,-n1);
                    a[x1][y1]=a[x1][y1]-n1;
                }
            }
            if(s[0]=='M')
            {
                scanf("%d%d%d%d%d",&x1,&y1,&x2,&y2,&n1);
                x1++;y1++;x2++;y2++;
                if(n1>=a[x1][y1])               //从x1,y1拿走n1本书放到x2,y2中
                {                               //如果不够,则拿走全部
                    updata(x1,y1,-a[x1][y1]);
                    updata(x2,y2,a[x1][y1]);
                    a[x2][y2]=a[x2][y2]+a[x1][y1];  //记录剩下的书
                    a[x1][y1]=0;
                }
                else
                {
                    updata(x1,y1,-n1);
                    updata(x2,y2,n1);
                    a[x2][y2]=a[x2][y2]+n1;         //记录剩下的书
                    a[x1][y1]=a[x1][y1]-n1;
                }
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值