HDU1009 FatMouse' Trade

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34583    Accepted Submission(s): 11314


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500
 
题目大意:一个老鼠有M pounds 猫的食物。在一个仓库中,有N个房间,每个房间有一个猫,老鼠拿猫的食物给去房间内 换取自己的食物。 换食物原则是,he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food.  他得到这个房间属于他的食物J[i]*a%,但是他得给猫F[i]*a。请你出一个策略,把老鼠手中的猫的食物换取更多自己的食物。
典型的贪心:
思路见AC代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef struct
{
    double J;           //自己能得到的食物
    double F;           //需要支出的食物
    double avar;        //性价比,就是自己得到食物与支出食物的比值,这就是贪心原则,越大越好。
}node;
node a[1010];
bool cmp(node x,node y)
{
    return x.avar>y.avar;
}
int main()
{
    double m;
    double av;
    int n,i;
    while(scanf("%lf%d",&m,&n)&&(m!=-1&&m!=-1))
    {
        av=0;
        for(i=0;i<n;i++)
        {
            scanf("%lf%lf",&a[i].J,&a[i].F);
            a[i].avar=a[i].J/a[i].F;
        }
        sort(a,a+n,cmp);
        for(i=0;i<n;i++)
        {
            if(m>=a[i].F)
            {
                av=av+a[i].J;
                m=m-a[i].F;
            }
            else
            {
                av=av+a[i].avar*m;
                break;
            }
        }
        printf("%.3lf\n",av);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值