CSP:2013.12.1出现次数最多的数
2021.11.21
题目
问题描述
给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。
输入格式
输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
输入的第二行有n个整数s1, s2, …, sn (1 ≤ si ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。
输出格式
输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。
样例输入
6
10 1 10 20 30 20
样例输出
10
解答思路
需要对每个数字进行计数,然后找出出现次数最多的数字,然后再找出次数最多的中最小的数字。我们可以声明一个较长的数组,使数字作为索引,数组中保存对应索引出现的次数,然后从索引0开始找出现次数最多的数即可。
代码C++
/*
2021.11.21
ccf试题1:出现次数最多的数
*/
#include <iostream>
using namespace std;
int times[10001];
int main(){
//接收数据大小
int n;
cin >>n;
//计数
int num;
for(int i=0; i<n; i++){
cin >>num;
times[num]++;
}
int max_times = 0;
int min_num;
for(int i=1; i<10001; i++){
if(max_times < times[i]){
max_times = times[i];
min_num = i;
}
}
//输出
cout <<min_num<<endl;
return 0;
}
代码java
//官网给的,可以参考下
import java.util.*;
import java.util.Map.Entry;
public class ChuXianZuiDuo {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
int[] array = new int[n];
int[] counts = new int[n];
for (int i = 0; i < n; i++) {
array[i] = sc.nextInt();
// counts[i] = 1;
}
Arrays.sort(array);
int count = 1;
Map<Integer, Integer> map = new TreeMap<Integer, Integer>();
for (int i = 0; i < n; i++) {
count = 1;
for (int j = 0; j < n; j++) {
if (array[i] == array[j]) {
count += 1;
map.put(array[i], count - 1);
}
}
}
int max = 0;
int value = 0;
Iterator<Map.Entry<Integer, Integer>> iter = map.entrySet().iterator();
while (iter.hasNext()) {
Map.Entry<Integer, Integer> entry = iter.next();
if (entry.getValue() > max ) {
value = entry.getKey();
max = entry.getValue();
}
}
System.out.println(value);
}
}