HDU 2614 Beat(DFS)

题目链接

Problem Description
Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
You should help zty to find a order of solving problems to solve more difficulty problem. 
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.
 
Input
The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.
 
Output
For each test case output the maximum number of problem zty can solved

Sample Input
3
0 0 0
1 0 1
1 0 0
3
0 2  2
1 0 1
1 1 0
5
0 1 2  3 1
0 0 2 3 1
0 0 0 3 1
0 0 0 0 2
0 0 0 0 0
 
Sample Output
3
2
4
 
Hint
Hint: sample one, as we know zty always solve problem 0 by costing 0 minute. So after solving problem 0, he can choose problem 1 and problem 2, because T01 >=0 and T02>=0. But if zty chooses to solve problem 1, he can not solve problem 2, because T12 < T01. So zty can choose solve the problem 2 second, than solve the problem 1.
 
题解:题目说的是zty做题目有一个奇怪的习惯,不会去做那些花费时间少于已经做过的题目所花时间的题,也就是说不会做更简单的题。在题目中,就是搜索的下一个位置的数字不能比之前的小。zty总是从第一题开始做起。
 
#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#include <map>
using namespace std;
//#define LOCAL
int pro[15][15],maxx,n;
bool vis[15];
void dfs(int p,int las,int cnt)
{
    int flag=0;
    for(int i=1; i<=n; i++)
    {
        if(!vis[i]&&(pro[p][i]>=las))
        {
            vis[i]=1;
            dfs(i,pro[p][i],cnt+1);
            vis[i]=0;
            flag=1;
        }
    }
    if(!flag)if(cnt>maxx)maxx=cnt;
}
int main()
{
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
#endif // LOCAL
    //Start
    while(cin>>n)
    {
        maxx=0;
        memset(pro,0,sizeof pro);
        memset(vis,0,sizeof vis);
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                cin>>pro[i][j];
        vis[1]=1;
        dfs(1,0,1);
        printf("%d\n",maxx);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/gpsx/p/5180109.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值