HDU 2614 Beat (dfs)

1 篇文章 0 订阅

HDU 2614 Beat (dfs)

Time limit 2000 ms
Memory limit 32768 kB
OS Windows

Problem Description
Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve

a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.

You should help zty to find a order of solving problems to solve more difficulty problem.

You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.

Input
The input contains multiple test cases.

Each test case include, first one integer n ( 2< n < 15).express the number of problem.

Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.

Output
For each test case output the maximum number of problem zty can solved.

Sample Input
3
0 0 0
1 0 1
1 0 0
3
0 2 2
1 0 1
1 1 0
5
0 1 2 3 1
0 0 2 3 1
0 0 0 3 1
0 0 0 0 2
0 0 0 0 0

Sample Output
3
2
4

Hint
Hint: sample one, as we know zty always solve problem 0 by costing 0 minute.
So after solving problem 0, he can choose problem 1 and problem 2, because T01 >=0 and T02>=0.
But if zty chooses to solve problem 1, he can not solve problem 2, because T12 < T01.
So zty can choose solve the problem 2 second, than solve the problem 1.

题目大意
这是一道dfs题。Zty对ACM很热情,想做各种各样的ACM难题。但TA有个习惯,就是不会去做比之前的题更简单的题目。比如做第一道题用了1秒钟,那么TA就不会去做耗时少于1秒钟的题目,只会做耗时大于等于1秒的题目。现在有N道题目,每道题目的难度不同,想你判断TA所能做的最大题目数。
i行j列Tij表示做完i题后去做j题所需要的时间。
借鉴了大神们的代码后加上了flag。
flag使题目数最大值的判断在解决题之后,判断是否做完所有的题目,或者是否做到某一题时无法做后面的题目。

代码:

#include <iostream>
#include <memory.h>
using namespace std;

int problem[16][16];
int vis[16];
int n,Ti;

int dfs(int line,int t,int s){		//上一题的题号、上一题的时间、所做题目数
	int i, flag =0;
	for(i=0;i<n;i++){
		if(i==line||vis[i]==1){		//判断题目是否做过
			continue;
		}
		if(problem[line][i]>=t){	//只有难度大于上一题时才做下一题
			vis[i]=1;
			dfs(i,problem[line][i],s+1);
			vis[i]=0;
			flag=1;
		}
	}
	if(!flag){
		Ti=s>Ti?s:Ti;
	}
	return Ti;
}

int main(){
	int i,j;
	while(cin>>n){
		memset(vis,0,sizeof(vis));	  //初始化vis
		for(i=0;i<n;i++)
			for(j=0;j<n;j++){
				cin>>problem[i][j];
			}
		vis[0]=1;					  //规定题目从第0题开始
		Ti=0;					  //完成的题目数
		dfs(0,0,1);
		cout<<Ti<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值