HDU 6027 Easy Summation【简单相加||快速幂】

Easy Summation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 965    Accepted Submission(s): 389


Problem Description
You are encountered with a traditional problem concerning the sums of powers.
Given two integers  n and  k. Let  f(i)=ik, please evaluate the sum  f(1)+f(2)+...+f(n). The problem is simple as it looks, apart from the value of  n in this question is quite large.
Can you figure the answer out? Since the answer may be too large, please output the answer modulo  109+7.
 

Input
The first line of the input contains an integer  T(1T20), denoting the number of test cases.
Each of the following  T lines contains two integers  n(1n10000) and  k(0k5).
 

Output
For each test case, print a single line containing an integer modulo  109+7.
 

Sample Input
 
  
3 2 5 4 2 4 1
 

Sample Output
 
  
33 30 10
 

Source

注意:
fast_pow(ll p, ll n)中p可能爆int需写成long long

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<map>
#include<set>
#include<stack>
#include<bitset>
#include<numeric>
#include<vector>
#include<string>
#include<iterator>
#include<cstring>
#include<ctime>
#include<functional>
#define INF 0x3f3f3f3f
#define ms(a,b) memset(a,b,sizeof(a))
#define pi 3.14159265358979
#define mod 1000000007
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;

typedef pair<int, int> P;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 55;


ll fast_pow(ll p, ll n)
{
	ll ans = 1;
	while (n)
	{
		if (n & 1) ans = (ans*p) % mod;
		p = (p*p) % mod;
		n >>= 1;
	}
	return ans;
}

int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		ll n, k, as = 0;
		scanf("%lld%lld", &n, &k);
		for (int i = 1; i <= n; i++)
		{
			as = (as + fast_pow(i, k)) % mod;
		}
		printf("%lld\n", as);
	}
}


转载于:https://www.cnblogs.com/Archger/p/8451648.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值