HDU 4442 Physical Examination【水题】【思维题】

Physical Examination

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8143    Accepted Submission(s): 2477


Problem Description
WANGPENG is a freshman. He is requested to have a physical examination when entering the university.
Now WANGPENG arrives at the hospital. Er….. There are so many students, and the number is increasing!
There are many examination subjects to do, and there is a queue for every subject. The queues are getting longer as time goes by. Choosing the queue to stand is always a problem. Please help WANGPENG to determine an exam sequence, so that he can finish all the physical examination subjects as early as possible.
 

Input
There are several test cases. Each test case starts with a positive integer n in a line, meaning the number of subjects(queues).
Then n lines follow. The i-th line has a pair of integers (ai, bi) to describe the i-th queue:
1. If WANGPENG follows this queue at time 0, WANGPENG has to wait for ai seconds to finish this subject.
2. As the queue is getting longer, the waiting time will increase bi seconds every second while WANGPENG is not in the queue.
The input ends with n = 0.
For all test cases, 0<n≤100000, 0≤a i,b i<2 31.
 

Output
For each test case, output one line with an integer: the earliest time (counted by seconds) that WANGPENG can finish all exam subjects. Since WANGPENG is always confused by years, just print the seconds mod 365×24×60×60.
 

Sample Input
 
  
5 1 2 2 3 3 4 4 5 5 6 0
 

Sample Output
 
  
1419
Hint
In the Sample Input, WANGPENG just follow the given order. He spends 1 second in the first queue, 5 seconds in the 2th queue, 27 seconds in the 3th queue, 169 seconds in the 4th queue, and 1217 seconds in the 5th queue. So the total time is 1419s. WANGPENG has computed all possible orders in his 120-core-parallel head, and decided that this is the optimal choice.
 

Source

现在王鹏要去体检,他一共要体检n个项目,这n个项目每个都有一个队列的人在排队,现在要求你找出王鹏体检完这n项一共要花多少时间?

输入:输入有多个实例,每个实例第一行为n(0<n≤100000),代表有n个项目队列,然后每行有两个数ai与bi (0≤ai,bi<2^31)。

ai表示如果他第0秒参加这个体检,需要用的时间。bi表示王鹏从第0秒开始每延迟1秒参加这个项目,需要多花bi秒的时间。(当然ai秒的时间是一定要花的)

输出:王鹏测完所有项目所要花的最短时间对(365*24*60*60)的余数。


考虑x和y两个分别在前面的情况。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
using namespace std;
const int maxn = 100010;
struct Node {
	long long a, b;
}node[maxn];

bool cmp(Node x, Node y)
{
	return x.a*y.b <= x.b*y.a;
}

int main()
{
	int n;
	const int mod = 365 * 24 * 60 * 60;
	while (~scanf("%d", &n) && n)
	{
		long long ans = 0;
		for (int i = 0; i < n; i++)
		{
			scanf("%lld%lld", &node[i].a, &node[i].b);
		}
		sort(node, node + n, cmp);
		for (int i = 0; i < n; i++)
		{
			ans = (ans + node[i].a + node[i].b*ans) % mod;
		}
		printf("%lld\n", ans);
	}
	return 0;
}




转载于:https://www.cnblogs.com/Archger/p/8451593.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值