HDU 4055 Number String【DP递推+递推优化】【好题】

Number String

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2033    Accepted Submission(s): 988


Problem Description
The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.
 

Input
Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.
 

Output
For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.
 

Sample Input
 
  
II ID DI DD ?D ??
 

Sample Output
 
  
1 2 2 1 3 6
Hint
Permutation {1,2,3} has signature "II". Permutations {1,3,2} and {2,3,1} have signature "ID". Permutations {3,1,2} and {2,1,3} have signature "DI". Permutation {3,2,1} has signature "DD". "?D" can be either "ID" or "DD". "??" gives all possible permutations of length 3.
 

Author
HONG, Qize
 

Source


dp[i][j] ,i表示前i个数的全排列,j表示最后一个数以j结束,dp中存可能的状态数

则为‘I’时,表示前面的结尾数比j要小,1 2 3,加进3则为1 2 3 3,无论如何都无法满足,则无法取到j,j最大到j-1

dp[i][j]=sum(dp[i-1][1]+.....+dp[i-1][j-1])

为‘D’时,前面的数都比插入的大,1 2 3时可加进3为1 2 3 3,此时将前面大于等于3 的数加1,为1 2 4 3,可以满足,所以后面j的下标从j开始,则

dp[i][j]=sum(dp[i-1][j]+....+dp[i-1][i-1])

为‘?’时,所有的数都有可能,则

dp[i][j]=sum(dp[i-1][1]+.....+dp[i-1][i-1])


注意过程中要用递推优化,用sum[i][j]表示dp[i][1]+...+dp[i][j]


#include<iostream>	
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<map>
#include<set>
#include<stack>
#include<bitset>
#include<numeric>
#include<vector>
#include<string>
#include<iterator>
#include<cstring>
#include<functional>
#define INF 0x3f3f3f3f
#define ms(a,b) memset(a,b,sizeof(a))
using namespace std;

const int maxn = 200010;
const int mod = 1e9 + 7;
const double pi = acos(-1.0);

typedef pair<int, int> P;
typedef long long ll;
typedef unsigned long long ull;

char s[1010];
int dp[1010][1010];
int num[1010][1010];

int main()
{
	while (~scanf("%s", s + 1))
	{
		int n = strlen(s + 1);
		dp[1][1] = 1;
		num[1][1] = 1;
		for (int i = 2; i <= n + 1; i++)
		{
			for (int j = 1; j <= i; j++)
			{
				if (s[i - 1] == 'I')
				{
					dp[i][j] = num[i - 1][j - 1] % mod;//for (int k = 1; k <= j - 1; k++)
				}
				else if (s[i - 1] == 'D')
				{
					dp[i][j] = (num[i - 1][i - 1] - num[i - 1][j - 1] + mod) % mod;//for (int k = j; k <= i - 1; k++)
				}
				else
				{
					dp[i][j] = num[i - 1][i - 1] % mod;//for (int k = 1; k <= i - 1; k++)
				}
				num[i][j] = (num[i][j - 1] + dp[i][j]) % mod;
			}
		}
		printf("%d\n", num[n+1][n+1]);
	}
}




转载于:https://www.cnblogs.com/Archger/p/8451630.html

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值