HDU - 4055 Number String(dp+前缀和优化)

The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter ‘I’ (increasing) if the second element is greater than the first one, otherwise write down the letter ‘D’ (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is “DIIDID”.

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.
Input
Each test case consists of a string of 1 to 1000 characters long, containing only the letters ‘I’, ‘D’ or ‘?’, representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The ‘?’ in these strings can be either ‘I’ or ‘D’.
Output
For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.
Sample Input
II
ID
DI
DD
?D
??
Sample Output
1
2
2
1
3
6

。。。dp还是很难想啊,想了半天也没想出来,枯了。。

思路:dp[i][j]表示只在前i个数里面选,以数字j为结尾的排列有多少种。

若s[i-1] == ‘I’ ----- dp[i][j] = ∑dp[i-1][x] (j<x<i)

若s[i-1] == ‘D’ ----- dp[i][j] = ∑dp[i-1][x] (1<x<=j)

若s[i-1] == ‘?’ ----- dp[i][j] = ∑dp[i-1][x] (1<x<i)

这样有个问题,就是最后加的这个数j它可能在前面已经出现过了,那么我们就把j前面>=它的数都+1(在想象中+1,,这样的话就满足题目要求了),这也是第二个式子中x可以等于j的原因。

还有个问题是,这样写的话时间复杂度是o(n^3),那么我们需要用到前缀和优化。那么状态转移方程就变为

若s[i-1] == ‘I’ ----- dp[i][j] = sum[i-1][j-1]

若s[i-1] == ‘D’ ----- dp[i][j] = sum[i-1][i-1]-sum[i-1][j-1]

若s[i-1] == ‘?’ ----- dp[i][j] = sum[i-1][i-1]

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
const int mod=1e9+7;
const int N =1005;
ll dp[N][N],sum[N][N];
int main()
{
	string s;
	while(cin>>s)
	{
		memset(dp,0,sizeof dp);	
		s=" "+s;	
		int n=s.size();
		dp[1][1]=sum[1][1]=1;
		for(int i=2;i<=n;i++)
		{
			for(int j=1;j<=i;j++)
			{
				if(s[i-1]=='I')
					dp[i][j]=sum[i-1][j-1];
				else if(s[i-1]=='D')
					dp[i][j]=(sum[i-1][i-1]-sum[i-1][j-1]+mod)%mod;
				else
					dp[i][j]=sum[i-1][i-1];
				sum[i][j]=(sum[i][j-1]+dp[i][j])%mod;
			}
		}
		ll ans=0;
		for(int i=1;i<=n;i++)
			ans=(ans+dp[n][i])%mod;
		cout<<ans<<endl;
	}
	return 0;
 } 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值