HDOJ 3123 GCC

Problem Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m
 
Input
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.  

Output
Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000
 
Sample Input
  
  
1 10 861017
 
Sample Output
  
  
593846
已AC:
#include <iostream>
#include <string>

int main()
{
    using namespace std;
    int T;
    cin >> T;
    while(T--)
    {
        string nstr;
        int m;
        cin >> nstr >> m;
        int nl;
        nl = nstr.size();
        int k, n = 0;
        if(nl>7)
            k = m-1;
        else
        {
            for(int i=0; i<nl; ++i)
            {
                n = n*10+nstr[i]-'0';
            }
            if(n>=m)
                k = m-1;
            else
                k = n;
        }
        long long temp = 1, sum = 1;
        for(int i=1; i<=k; ++i)
        {
            temp = (temp*i)%m;
            sum = (sum+temp)%m;
            if(!temp)
                break;
        }
        cout << sum%m << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值