统计难题

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 12620    Accepted Submission(s): 5330


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
  
  
banana band bee absolute acm ba b band abc
 

Sample Output
  
  
2 3 1 0
 

Author
Ignatius.L
 

Recommend
Ignatius.L
 
注意本题用遍历暴力破解会超时!!!!

trie的num保存经过这一部分的字符串数目!

然后。。。。没要解释的了。。。

ac代码:

82178652013-05-02 16:38:18Accepted1251109MS45804K2036 BC++

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <sstream>
#include <vector>
#include <stack>
#include <map>
#include <queue>
#include <set>
#include <iostream>
#include <stdlib.h>
#include<cctype>
#define rep(i,s,e) for(int i = (s);i<=(e);++i)
#define maxn 100100
#define INF 1000000000
using namespace std;
const int nodeNum = 26;
const char base  = 'a';
struct Trie
{
    int num;
    bool terminal;//叶子节点
    struct Trie* son[nodeNum];//子节点
};
Trie* NewTrie()//建树(只有根节点)
{
    Trie* temp = new Trie;
    temp ->num = 1;
    temp ->terminal = false;
    for(int i = 0;i<nodeNum;++i)
    temp ->son[i] = NULL;
    return temp;
}
void insert(Trie* pnt,char* s)
{
    Trie* temp = pnt;
    int len = strlen(s);
    for(int i = 0;i<len;++i)
    {
        if(temp->son[s[i]-base]==NULL)
        temp ->son[s[i]-base] = NewTrie();
        else
        temp->son[s[i]-base]->num++;
        temp = temp->son[s[i]-base];
    }
    temp->terminal = true;
}

void Delete(Trie* pnt)
{
    if(pnt!=NULL)
    {
        for(int i = 0;i<nodeNum;++i)
        {
            if(pnt->son[i]!=NULL)
            Delete(pnt->son[i]);
            delete pnt;
            pnt = NULL;
        }
    }
}

Trie* find(Trie* pnt,char* s)
{
    int len  = strlen(s);
    Trie* temp = pnt;
    for(int i = 0;i<len;++i)
    {
        if(temp->son[s[i]-base]!=NULL)
        temp = temp->son[s[i]-base];
        else
        return NULL;
    }
    return temp;
}
char str[maxn][20];
int main()
{
    //freopen("in.txt","r",stdin);
    Trie* tree = NewTrie();
    int i = 0;
    while(gets(str[i]))
    {
        if(strcmp(str[i],"\0")==0)
        break;
        insert(tree,str[i]);
        i++;
    }
    char s[100];
    while(scanf("%s",s)==1)
    {

        if(find(tree,s))
        {
          printf("%d\n",find(tree,s)->num);
        }else
        printf("0\n");
        //continue;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值