转载:http://forum.byr.edu.cn/article/ACM_ICPC/51264
大家懂的,鉴于HDU用的是windows服务器,所以stack大小及其坑爹,稍微深一点的递归栈就会stack overflow。
通常的规避方法是用stack或者手写stack模拟栈的递归过程。这个极其蛋疼啊,而且被卡了STL也很得不偿失唉。(话说这一切都是基于非现场赛来说的,现场赛怎么会卡你这些玩艺儿。)从Lost(庄立大神)那里学来一种规避栈溢出的方法。
在文件gui头处加上这么一句
#pragma comment(linker, "/STACK:1024000000,1024000000")
后面两个数字随便写。。。你觉得能过就好,另外不要超了栈内存的真正上限。
基于VC++的编译预处理命令,不知道GNU C++上面有没有对应的方式。
去MSDN看一眼就会找到对这一句的对应说明,大概在编译器选项那里。
当然咯,这个代码必须拿C++来提交,所以C++会出现的那种long long 和__int64的问题也要注意到。。。
某题我stack模拟dfs 2500+ms,开放了栈内存的普通dfs 300+ms。。。不解释。。windows伤不起啊。
来一个例子:
Island Transport
Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 2943 Accepted Submission(s): 958
Problem Description
In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships.
You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.
You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.
Input
The first line contains one integer T (1<=T<=20), the number of test cases.
Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.
Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.
Output
For each test case, output an integer in one line, the transport capacity.
Sample Input
2 5 7 3 3 3 0 3 1 0 0 4 5 1 3 3 2 3 4 2 4 3 1 5 6 4 5 3 1 4 4 3 4 2 6 7 -1 -1 0 1 0 2 1 0 1 1 2 3 1 2 1 2 3 6 4 5 5 5 6 3 1 4 6 2 5 5 3 6 4
Sample Output
9 6
Source
#include"stdio.h"
#include"string.h"
#pragma comment(linker, "/STACK:1024000000,1024000000")//外挂开栈
#define inf 99999999
int min(int a,int b)
{
return a<b?a:b;
}
int e,head[100005];
int level[100005];
int q[100005];
struct node
{
int to,val;
int next;
}edge[200005];
void add_edge(int x,int y,int w)
{
edge[e].to=y;
edge[e].val=w;
edge[e].next=head[x];
head[x]=e++;
edge[e].to=x;
edge[e].val=w;
edge[e].next=head[y];
head[y]=e++;
}
bool bfs(int s,int t)
{
int front=0,rear=0;
int top,k;
q[rear++]=s;
memset(level,0,sizeof(level));
level[s]=1;
while(front<rear)
{
top=q[front++];
if(top==t)
return true;
for(k=head[top];k!=-1;k=edge[k].next)
{
if(!level[edge[k].to]&&edge[k].val>0)
{
level[edge[k].to]=level[top]+1;
q[rear++]=edge[k].to;
}
}
}
return false;
}
int dfs(int now,int maxf,int t)
{
int ret=0,f,k;
if(now==t)
return maxf;
for(k=head[now];k!=-1;k=edge[k].next)
{
if(level[edge[k].to]==level[now]+1&&edge[k].val>0)
{
f=dfs(edge[k].to,min(maxf-ret,edge[k].val),t);
edge[k].val-=f;
edge[k^1].val+=f;
ret+=f;
if(ret==maxf)
return ret;
}
}
if(ret==0)
level[now]=0;
return ret;
}
int dinic(int s,int t)
{
int ans=0;
while(bfs(s,t))
ans+=dfs(s,inf,t);
return ans;
}
int main( )
{
int T,i,n,m,s,t;
int x,y,w,ps,pt;
scanf("%d",&T);
while(T--)
{
e=0;s=inf;t=0;
memset(head,-1,sizeof(head));
scanf("%d%d",&n,&m);
for(i=1;i<=n;i++)
{
scanf("%d%d",&x,&y);
if(s>x)
{s=x;ps=i;}
if(t<x)
{t=x;pt=i;}
}
for(i=1;i<=m;i++)
{
scanf("%d%d%d",&x,&y,&w);
add_edge(x,y,w);
}
printf("%d\n",dinic(ps,pt));
}
return 0;
}