后缀数组&&KMP

4 篇文章 0 订阅
0 篇文章 0 订阅

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 26381 Accepted: 11042

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source



因为题目已经确定给定字符串由一个特别的子串重复多次得到那么刚好可以用getnext函数得到答案:
//匹配到最后一个字符会有一个j = next[j]
    //j就是遇到最后一个字符应转到的字符
    //于是之间的长度就是temp
AC代码:
#include<math.h>
#include<algorithm>
#include<string.h>
#include<iostream>
#include<sstream>
#include<stdio.h>
#define maxn 1000010
using namespace std;
int getNext(char* p,int* next)
{
    int ans;
    int m = strlen(p);
    next[0] = 0;
    next[1] = 0;
    int j;
    for(int i = 1;i<m;++i)//千万不能是m-1
    {
        j = next[i];
        while(j&&p[i]!=p[j])
        j = next[j];
        next[i+1] = p[i]==p[j] ? j+1 : 0;
    }

    int temp = m - j  - 1;
    if(m%temp==0)
    {
       ans = m / temp;
    }
    else
    ans = 1;
    return ans;
}
int next[maxn];
char str[maxn];
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%s",str)==1&&str[0]!='.')
    {
        int ans = getNext(str,next);
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值