Max Sum
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4
Case 2: 7 1 6
AC代码:
#include<cstdio>
int main(){
int c;
scanf("%d",&c);
for(int t=1;t<=c;t++){
int n,x;
int maxSum=-10000,thisSum=0;
int start_index=1,end_index=1,e=1;
scanf("%d",&n);
for(int i=1;i<=n;i++){
scanf("%d",&x);
thisSum+=x;
if(thisSum>maxSum){
start_index=e;
end_index=i;
maxSum=thisSum;
}
if(thisSum<0){ //这里不可以用else if?
e=i+1;
thisSum=0;
}
}
printf("Case %d:\n",t);
printf("%d %d %d\n",maxSum,start_index,end_index);
if(t!=c) printf("\n");
}
return 0;
}