HD1003(Max Sum)

HD1003

Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 184036 Accepted Submission(s): 42956

Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

下面是我下写的代码:

#include<stdio.h>
#include<stdlib.h>
int main()
{
    int t,sum=0,first,last,i,j,k,max,n;
    int *a; 
    scanf("%d",&t);
    for(k=1;k<=t;k++)
    {
        scanf("%d",&n);
        a=(int *)malloc(sizeof(int)*(n+1));  
        if(1==n)
        {
        first=1;
        last=1;
    }
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        i=1;
        max=a[i];
        for(j=1;j<=n;j++){
            for(i=j;i<=n;i++)
            {
            sum=sum+a[i];
            if(sum>max)
            {
                max=sum;
                first=j;
                last=i; 
            }   
            }
            sum=0;
        }
        printf("Case %d:\n%d %d %d\n",k,max,first,last);    
        printf("\n");
        free(a);    
    }
    return 0;
 } 

虽然在本机测试成功

这里写图片描述


但是在杭电OJ上一直过不了。

这里写图片描述


因为题目中要求T<=100000,而我的算法中,时间复杂度达到了O(n²),而O(n²)所能解决的最大规模如下

这里写图片描述


解决办法是用动态分配(Dynamic Programming)把时间复杂度降为O(n)即可,代码如下

#include<stdio.h>
int main()
 {
     int t,n,a,i,j,start,end,temp;
     long max,sum;
     scanf("%d",&t);
     for(i=1;i<=t;i++)
     {
         sum=0;
         temp=1;
         max=-1001;          
         scanf("%d",&n);
         for(j=1;j<=n;j++)
         {
             scanf("%d",&a);
             sum=sum+a;
             if(sum>max)
             {
                 max=sum;
                 start=temp; 
                 end=j;     
             }
            if(sum<0)
             {
                 sum=0;
                 temp=j+1;
            }
         }
        printf("Case %d:\n%d %d %d\n",i,max,start,end);
         if(i<t)
            printf("\n");
     }
     return 0;
 }

结果AC

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值