Cure(1+1/2+1/4/1/9+1/16+....+1/n*n)

Cure

Time Limit : 3000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 8 Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Given an integer n, we only want to know the sum of 1/k2 where k from 1 to n.

Input

There are multiple cases.
For each test case, there is a single line, containing a single positive integer n.
The input file is at most 1M.

Output

The required sum, rounded to the fifth digits after the decimal point.

Sample Input

1
2
4
8
15

Sample Output

1.00000
1.25000
1.42361
1.52742
1.58044

笔记:错了好几次,坑点1:输入一定要用字符串; 坑点2:将每个答案先存储起来; 坑点3:大概当n=150000时,后面的数约等于0。

正确代码:

#include<iostream>
#include<stdio.h>
#include<cmath>
using namespace std;
long long maxn=1500008;
double num[1500208];
void init(){
	num[1]=1;
	for(long long i=2;i<=maxn;i++){
		num[i]=num[i-1]+((1.0/i)*(1.0/i));
	}
}
int main(){
	init();
	string s;
	while(cin>>s){
		int len=s.length();
		int f=0;
		long long n=0;
		for(int i=0;i<len;i++){
			n=n*10+(s[i]-'0');
			if(n>150000){
				f=1;
				break;
			}
		} 
		if(f){
			printf("%.5f\n",num[150000]);
		}
		else{
			printf("%.5f\n",num[n]);
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值