数据结构实验之链表二:逆序建立链表

使用C语言
Problem Description
输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。
Input
第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。
Output
依次输出单链表所存放的数据。
Sample Input

10
11 3 5 27 9 12 43 16 84 22

Sample Output

22 84 16 43 12 9 27 5 3 11

Hint
不能使用数组!

#include <stdio.h>
#include <stdlib.h>
struct node
{
  int data;
  struct node *next;
};
int main()
{
    int n,i;
    struct node *head,*tail,*p;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
      p=(struct node *)malloc(sizeof(struct node));
      scanf("%d",&p->data);
      p->next=head->next;
      head->next=p;

    }
    for(p=head->next;p!=NULL;p=p->next)
    {
      if(p->next==NULL)  printf("%d\n",p->data);
      else printf("%d ",p->data);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值