1733: 旋转图像(模拟)

1733: 旋转图像

时间限制: 1 Sec  内存限制: 128 MB
提交: 986  解决: 429
[提交][状态][讨论版][命题人:admin]

题目描述

输入

输出

样例输入

2
2 3
111
000
90
3 3
111
101
111
180

样例输出

01
01
01
111
101
111


#include <iostream>
#include <algorithm>

using namespace std ; 

int t , n , m ; 
char map[60][60] ; 
int result[60][60] ; 
int angle ; 

void solve(){

    if(angle==0){
        for(int i=1 ; i<=n ; i++){
            for(int j=1 ; j<=m ; j++){
                cout << result[i][j] ; 
             }
             cout << endl ; 
        }
    }else if(angle == 90){
        for(int  j=1 ; j<=m ; j++){
            for(int i=n ; i>=1 ; i--){
                cout << result[i][j] ; 
            }
            cout << endl ; 
        }
    }else if(angle == 180){
        for(int i=n ; i>=1 ; i--){
            for(int j=m ; j>= 1 ; j--){
                cout << result[i][j] ; 
            }
            cout << endl ; 
        }
    }else if(angle == 270){
        for(int j=m ; j>=1 ; j--){
            for(int i=1 ; i<=n ; i++){
                cout << result[i][j] ; 
            }
            cout << endl ; 
        }
    }
    return; 
}

int  main(){
    cin >> t  ; 
    while(t--){
        cin >> n >> m ; 
        
        for(int i=1 ; i<=n ; i++){
            scanf("%s" , map[i] + 1 ) ; 
            for(int j=1 ; j<=m ; j++){
                result[i][j] = map[i][j] - '0' ; 
            }
        }
        cin >> angle ; 
        solve() ; 
    }
    return 0 ;    
}

 

 

转载于:https://www.cnblogs.com/yi-ye-zhi-qiu/p/8942166.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值